Bug 16380 - Can't mkfs on partitions > 8 (mkswaps fails, too)
Can't mkfs on partitions > 8 (mkswaps fails, too)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-16 12:59 EDT by Dan Yocum
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 12:59:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Yocum 2000-08-16 12:59:10 EDT
Probably related to 14490 as well.  I can create partitions (total number
fewer than 8) with
fdisk, but can't mkfs or mkswap on hda9 or above.  Errors follow.

# mkfs /dev/hda9
mke2fs 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
/dev/hda9: Invalid argument passed to ext2 library while setting up
superblock

# mkswap /dev/hda9 
mkswap: error: swap area needs to be at least 40kB
Usage: mkswap [-c] [-v0|-v1] [-pPAGESZ] /dev/name [blocks]

Cheers,
Dan
Comment 1 Dan Yocum 2000-08-21 12:33:15 EDT
Never mind... operator error, mostly.  But it shouldn't have worked as well as
it did - I had labeled /dev/hda7 as my swap partition and was trying to mount it
again as a real partition, which actually worked, but didn't give me whole size
of the real partition.  Whatever.  It ain't a bug.

Cheers,
Dan

Note You need to log in before you can comment on or make changes to this bug.