Bug 1638325 - ceph-validate : osd_auto_discovery - first letter lower case boolean values are not accepted
Summary: ceph-validate : osd_auto_discovery - first letter lower case boolean values a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 3.2
Assignee: Andrew Schoen
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks: 1630975
TreeView+ depends on / blocked
 
Reported: 2018-10-11 10:47 UTC by ymane
Modified: 2019-01-03 19:02 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-ansible-3.2.0-0.1.rc2.el7cp Ubuntu: ceph-ansible_3.2.0~rc2-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible.log file (419.01 KB, text/plain)
2018-10-11 10:47 UTC, ymane
no flags Details


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3278 None None None 2018-10-30 18:48:09 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:17 UTC

Description ymane 2018-10-11 10:47:42 UTC
Created attachment 1492859 [details]
ansible.log file

Description of problem:

osd_auto_discovery is not working


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Added osd_auto_discovery:true in hosts file
2.executed playbook
3.

Actual results:

[ERROR]: [magna111] Validation failed for variable: osd_auto_discovery

 [ERROR]: [magna111] Given value for osd_auto_discovery: true

 [ERROR]: [magna111] Reason: not of type boolean

fatal: [magna111]: FAILED! => {
    "changed": false, 
    "msg": "[magna111] Validation failed for variable: osd_auto_discovery\n[magna111] Reason: not of type boolean\n[magna111] Given value for osd_auto_discovery: true", 
    "stderr_lines": [
        "[magna111] Validation failed for variable: osd_auto_discovery"
    ]
}



Expected results:

No error

Additional info:

Comment 4 Vasishta 2018-10-30 14:19:42 UTC
Hi,

It can be observed that natario.validate was not considering 'true' as a valid value for dmcrypt and osd_auto_discovery and other flags. I feel that it would be better if we support flags to be set as 'true' or 'false' also.

As I very simple method plugins/actions/validate.py can be modified as in -

https://github.com/ceph/ceph-ansible/compare/master...VasishtaShastry:ceph_val_accept_small_case_bool

It seemed to be working.

Regards,
Vasishta Shastry
QE, Ceph

Comment 5 Andrew Schoen 2018-10-30 18:48:09 UTC
Vasishta,

I've made an upstream pull request from your branch. This solution looks good to me.

Thanks,
Andrew

Comment 6 leseb 2018-10-31 08:14:18 UTC
Put it in back to assigned. Only use POST when the patch has been backported.

Comment 11 Vasishta 2018-11-30 03:18:43 UTC
Working fine for both osd_auto_discovery and dmcrypt using ceph-ansible-3.2.0-0.1.rc4.el7cp.noarch .



$ cat /etc/ansible/hosts
.....

[osds]
abc24 osd_auto_discovery='true'
abc07 dmcrypt='true' devices="['/dev/sdb']"
abc32 devices="['/dev/sdb','/dev/sdc']"


....

Moving to VERIFIED state.


Regards,
Vasishta shastry
QE, Ceph

Comment 13 errata-xmlrpc 2019-01-03 19:02:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.