Bug 1638466 - jenkins deployments from quickstart templates fail (/usr/libexec/s2i/run: line 472: exec: java: not found)
Summary: jenkins deployments from quickstart templates fail (/usr/libexec/s2i/run: lin...
Keywords:
Status: CLOSED DUPLICATE of bug 1630265
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Gabe Montero
QA Contact: Dongbo Yan
URL:
Whiteboard:
Depends On:
Blocks: 1724792
TreeView+ depends on / blocked
 
Reported: 2018-10-11 16:19 UTC by Mark LaBonte
Modified: 2019-06-28 16:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-11 16:53:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mark LaBonte 2018-10-11 16:19:30 UTC
Description of problem:

After a clean install of OCP 3.10, jenkins deployments are failing:

[root@dhcp-8-32-121 ~]# oc new-app -f /usr/share/openshift/examples/quickstart-templates/jenkins-ephemeral-template.json 
--> Deploying template "myproject/jenkins-ephemeral" for "/usr/share/openshift/examples/quickstart-templates/jenkins-ephemeral-template.json" to project myproject

     Jenkins (Ephemeral)
     ---------
     Jenkins service, without persistent storage.
     
     WARNING: Any data stored will be lost upon pod destruction. Only use this template for testing.

     A Jenkins service has been created in your project.  Log into Jenkins with your OpenShift account.  The tutorial at https://github.com/openshift/origin/blob/master/examples/jenkins/README.md contains more information about using this template.

     * With parameters:
        * Jenkins Service Name=jenkins
        * Jenkins JNLP Service Name=jenkins-jnlp
        * Enable OAuth in Jenkins=true
        * Memory Limit=512Mi
        * Jenkins ImageStream Namespace=openshift
        * Disable memory intensive administrative monitors=false
        * Jenkins ImageStreamTag=jenkins:2

--> Creating resources ...
    route "jenkins" created
    deploymentconfig "jenkins" created
    serviceaccount "jenkins" created
    rolebinding "jenkins_edit" created
    service "jenkins-jnlp" created
    service "jenkins" created
--> Success
    Access your application via route 'jenkins-myproject.css-group.com' 
    Run 'oc status' to view your app.
[root@dhcp-8-32-121 ~]# oc get pod
NAME               READY     STATUS             RESTARTS   AGE
jenkins-1-86ph4    0/1       CrashLoopBackOff   2          57s
jenkins-1-deploy   1/1       Running            0          1m
[root@dhcp-8-32-121 ~]# oc logs jenkins-1-86ph4
alternatives version 1.7.4 - Copyright (C) 2001 Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public License.
usage: alternatives --install <link> <name> <path> <priority>
                    [--initscript <service>]
                    [--family <family>]
                    [--slave <link> <name> <path>]*
       alternatives --remove <name> <path>
       alternatives --auto <name>
       alternatives --config <name>
       alternatives --display <name>
       alternatives --set <name> <path>
       alternatives --list
common options: --verbose --test --help --usage --version --keep-missing
                --altdir <directory> --admindir <directory>
alternatives version 1.7.4 - Copyright (C) 2001 Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public License.
usage: alternatives --install <link> <name> <path> <priority>
                    [--initscript <service>]
                    [--family <family>]
                    [--slave <link> <name> <path>]*
       alternatives --remove <name> <path>
       alternatives --auto <name>
       alternatives --config <name>
       alternatives --display <name>
       alternatives --set <name> <path>
       alternatives --list
common options: --verbose --test --help --usage --version --keep-missing
                --altdir <directory> --admindir <directory>
OPENSHIFT_JENKINS_JVM_ARCH='', CONTAINER_MEMORY_IN_MB='512', using /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64/jre/bin/java and 
/usr/local/bin/jenkins-common.sh: line 33: java: command not found
mkdir: cannot create directory ‘/var/lib/jenkins/logs’: File exists
Administrative monitors that contact the update center will remain active
Detected password environment variable change, updating Jenkins configuration ...
Migrating slave image configuration to current version tag ...
+ exec java -XX:+UseParallelGC -XX:MinHeapFreeRatio=5 -XX:MaxHeapFreeRatio=10 -XX:GCTimeRatio=4 -XX:AdaptiveSizePolicyWeight=90 -Xmx256m -Dfile.encoding=UTF8 -Djavamelody.displayed-counters=log,error -Duser.home=/var/lib/jenkins -Djavamelody.application-name=JENKINS -jar /usr/lib/jenkins/jenkins.war
/usr/libexec/s2i/run: line 472: exec: java: not found
[root@dhcp-8-32-121 ~]# 


Version-Release number of selected component (if applicable):

[root@dhcp-8-32-121 ~]# oc version
oc v3.10.45
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://dhcp-8-32-121.css.lab.eng.rdu2.redhat.com:8443
openshift v3.10.45
kubernetes v1.10.0+b81c8f8
[root@dhcp-8-32-121 ~]# 


How reproducible:


Steps to Reproduce:

1. Perform a clean install of OCP 3.10
2. Deploy Jenkins (ephemeral or persistent) using templates at:
/usr/share/openshift/examples/quickstart-templates/

Actual results:

crashloopbackoff on jenkins pod

Expected results:

jenkins pod should deploy successfully

Additional info:

[root@dhcp-8-32-121 ~]# oc describe image sha256:9f54c6fe5c441db1eb6bf511abfcb2432638f06eae49569bc5aaa9510353afb0 
Docker Image:	registry.access.redhat.com/openshift3/jenkins-2-rhel7@sha256:9f54c6fe5c441db1eb6bf511abfcb2432638f06eae49569bc5aaa9510353afb0
Name:		sha256:9f54c6fe5c441db1eb6bf511abfcb2432638f06eae49569bc5aaa9510353afb0
Created:	47 hours ago
Annotations:	image.openshift.io/dockerLayersOrder=ascending
Image Size:	486.6MB (first layer 74.93MB, last binary layer 270.8MB)
Image Created:	13 days ago
Author:		Ben Parees <bparees@redhat.com>
Arch:		amd64
Entrypoint:	/usr/bin/dumb-init --
Command:	/usr/libexec/s2i/run
Working Dir:	/var/lib/origin
User:		1001
Exposes Ports:	50000/tcp, 53/tcp, 8080/tcp, 8443/tcp
Docker Labels:	License=GPLv2+
		architecture=x86_64
		authoritative-source-url=registry.access.redhat.com
		build-date=2018-09-28T00:02:22.035902
		com.redhat.build-host=cpt-0011.osbs.prod.upshift.rdu2.redhat.com
		com.redhat.component=openshift-jenkins-2-container
		description=Jenkins is a continuous integration server
		distribution-scope=public
		io.k8s.description=Jenkins is a continuous integration server
		io.k8s.display-name=Jenkins 2
		io.openshift.expose-services=8080:http
		io.openshift.s2i.scripts-url=image:///usr/libexec/s2i
		io.openshift.source-commit-url=https://github.com/openshift/jenkins/commit/e61628b226988878037370bbe798ff50538c6e22
		io.openshift.source-repo-commit=e61628b226988878037370bbe798ff50538c6e22
		io.openshift.source-repo-url=https://github.com/openshift/jenkins
		io.openshift.tags=jenkins,jenkins2,ci
		maintainer=Red Hat, Inc.
		name=openshift3/jenkins-2-rhel7
		release=7
		summary=Provides the latest release of Red Hat Enterprise Linux 7 in a fully featured and supported base image.
		url=https://access.redhat.com/containers/#/registry.access.redhat.com/openshift3/jenkins-2-rhel7/images/v3.10.45-7
		usage=This image is very generic and does not serve a single use case. Use it as a base to build your own images.
		vcs-ref=d3bf7f1910f53bc1da8725c3192736e0fab8b27b
		vcs-type=git
		vendor=Red Hat, Inc.
		version=v3.10.45
Environment:	PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.ppc64le/jre/bin/
		container=oci
		HOME=/var/lib/jenkins
		KUBECONFIG=/var/lib/origin/openshift.local.config/master/admin.kubeconfig
		JENKINS_VERSION=2
		JENKINS_HOME=/var/lib/jenkins
		JENKINS_UC=https://updates.jenkins.io
		OPENSHIFT_JENKINS_IMAGE_VERSION=3.10
		LANG=en_US.UTF-8
		LC_ALL=en_US.UTF-8
Volumes:	/var/lib/jenkins
[root@dhcp-8-32-121 ~]#

Comment 1 Ben Parees 2018-10-11 16:20:46 UTC
Gabe, please dupe this against the appropriate bug, i assume this is the missing java runtimes issue still.

Comment 2 Gabe Montero 2018-10-11 16:53:11 UTC
it is the same 32bit issue

*** This bug has been marked as a duplicate of bug 1630265 ***


Note You need to log in before you can comment on or make changes to this bug.