Bug 1638605 - Nautilus crashes every time you search in the overview
Summary: Nautilus crashes every time you search in the overview
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carlos Soriano
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F29FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-10-12 04:14 UTC by Tomas Popela
Modified: 2018-10-12 16:17 UTC (History)
12 users (show)

Fixed In Version: nautilus-3.30.2-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-12 16:17:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomas Popela 2018-10-12 04:14:13 UTC
Description of problem:
Nautilus 3.30 crashes every time you search something in the GNOME Shell's overview.

Version-Release number of selected component (if applicable):
3.30.0 and 3.30.1

How reproducible:
Always

Additional info:
Fixed with https://gitlab.gnome.org/GNOME/nautilus/merge_requests/323 that will be part of the 3.30.0.1 release.

Comment 1 Tomas Popela 2018-10-12 04:16:25 UTC
Proposing for Final freeze exception.

Comment 2 Adam Williamson 2018-10-12 05:11:33 UTC
Note, it's not "always" reproducible in the sense that it crashes for everyone - it doesn't. It seems like there's some kind of timing/race element to this where it actually crashes very commonly for a few people, but not for most.

+1 FE, obviously we don't want anyone to hit this if we can avoid it.

Comment 3 Fedora Update System 2018-10-12 12:37:19 UTC
nautilus-3.30.2-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e63b73ea9a

Comment 4 Lukas Ruzicka 2018-10-12 13:32:10 UTC
The update works for me and does not crash.

Comment 5 Adam Williamson 2018-10-12 15:08:59 UTC
CCing a few usual suspects for FE votes.

Comment 6 Stephen Gallagher 2018-10-12 15:09:57 UTC
+1 FE

This would look bad on the Live media.

Comment 7 Kalev Lember 2018-10-12 15:17:51 UTC
+1 FE

Comment 8 Adam Williamson 2018-10-12 16:03:42 UTC
That's +3.

Comment 9 Fedora Update System 2018-10-12 16:17:25 UTC
nautilus-3.30.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.