Bug 163905 - Keyboard shortcuts in 1.9.117 showing up as three question marks
Keyboard shortcuts in 1.9.117 showing up as three question marks
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-21 17:02 EDT by Linda Worthington
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.9.125
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 04:00:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
??? + O Menu Error (26.49 KB, image/png)
2005-07-21 17:12 EDT, Linda Worthington
no flags Details

  None (edit)
Description Linda Worthington 2005-07-21 17:02:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Updated to OpenOffice.org 1.9.117 with up2date and 85% of the time the keyboard shortcuts in the menu are three question marks instead of saying Control.  The functions still work even with the three question marks.

Version-Release number of selected component (if applicable):
OpenOffice.org 1.9.117

How reproducible:
Sometimes

Steps to Reproduce:
1.Open OpenOffice.org Writer, Draw, Impress, Base, Calc, Math.
2.File >
3.
  

Actual Results:  When the drop down menu shows instead of the keyboard shortcuts reading Control + O it says ??? + O.

Expected Results:  The three ? marks should be the word Control.

Additional info:

Even though the word Control is showing as three ? marks, the function still works.  The menu says, for example, ??? + O but I can use Ctrl + O and get the expected result.  Anywhere in the menu there should be the word Control it is three ? marks when this happens.  This happens 80% of the time just opening OpenOffice.org any module.
Comment 1 Linda Worthington 2005-07-21 17:02:50 EDT
This happens in KDE and Gnome.
Comment 2 Linda Worthington 2005-07-21 17:12:58 EDT
Created attachment 117035 [details]
??? + O Menu Error

I just opened Writer and this is a screenshot of my menu.
Comment 3 Caolan McNamara 2005-07-22 03:57:03 EDT
This implies that it cannot find the name for "Ctrl" and "Alt" to put into those
menus, so either OOo has changed its behaviour for searching for the right names
to use here, or where it gets the names has changed.

I suspect that where it gets the names, from some X lib or property, has changed
somehow.
Comment 4 Caolan McNamara 2005-07-22 04:31:17 EDT
it's got to be coming from this code... But I'm not seeing it on rawhide at the
moment.

caolanm->mharris: any known problems on the X side about getting keysym names
for Ctrl ?

String SalDisplay::GetKeyNameFromKeySym( KeySym nKeySym ) const
{
        String aRet;

    // return an empty string for keysyms that are not bound to
    // any key code
    XLIB_KeyCode aKeyCode = XKeysymToKeycode( GetDisplay(), nKeySym );
    if( aKeyCode != 0 && aKeyCode != NoSymbol )
    {
        if( !nKeySym )
            aRet = String::CreateFromAscii( RTL_CONSTASCII_STRINGPARAM( "???" ) );
        else
        {
            aRet = ::vcl_sal::getKeysymReplacementName(
const_cast<SalDisplay*>(this)->GetKeyboardName(), nKeySym );
            if( ! aRet.Len() )
            {
                const char *pString = XKeysymToString( nKeySym );
                int n = strlen( pString );
                if( n > 2 && pString[n-2] == '_' )
                    aRet = String( pString, n-2, RTL_TEXTENCODING_ISO_8859_1 );
                else
                    aRet = String( pString, n, RTL_TEXTENCODING_ISO_8859_1 );
            }
        }
    }
        return aRet;
}
Comment 5 Linda Worthington 2005-07-22 11:10:37 EDT
Not sure if this is associated but since the OOo update I am loosing my repeat
rate on my keyboard.  I can usually hold down the backspace key and take out
some type but now I have to hit the key every time for every letter or space.  I
can log out and log back in and the repeat rate is there until I open OOo and I
lose it again.  I didn't have this problem until the 117 update yesterday.  
Comment 6 Linda Worthington 2005-07-25 08:31:11 EDT
Just an update.  I have tested this in Gnome and KDE with the same results for
the ??? issue and keyboard issue.  Thanks!
Comment 7 Linda Worthington 2005-08-04 17:47:47 EDT
Is there any resoultion for this bug?  Loosing my repeat rate on the keyboard
has become quite a problem with 95 pages of documentation to edit and submit in
less than 3 days.  When this happens I have to close all apps, log out and log
back in to get the repeat rate back.  Thanks!
Comment 8 Caolan McNamara 2005-08-24 07:30:09 EDT
I suspect this is an X bug, and nothing to do with OOo, I've been unable to
reproduce it. But there is now a testing update for fc4 to openoffice.org
1.9.125 in case it is OOo related to see if it remains
Comment 9 Caolan McNamara 2005-08-31 03:47:42 EDT
Is this still the case with 1.9.125 update ?
Comment 10 Linda Worthington 2005-08-31 07:41:45 EDT
The problem has been resolved with the update.  Thanks!!
Comment 11 Caolan McNamara 2005-08-31 07:43:12 EDT
cool, that's an unexpected win.
Comment 12 Linda Worthington 2005-09-27 07:15:34 EDT
Well the problem is back. Not sure what the issue is. I am running 1.9.125 with
the latest kernel. I opened an sxw file and now I have the three question marks
instead of the keyboard shortcuts even after reboot. 

Note You need to log in before you can comment on or make changes to this bug.