Bug 163911 - kickstart probes block devices it shouldn't and halts automated install process
kickstart probes block devices it shouldn't and halts automated install process
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-21 17:31 EDT by Axel Thimm
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-26 00:10:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2005-07-21 17:31:21 EDT
Description of problem:
Trying to deploy RHEL4 with kickstart on a SAN-cluster fails, as anaconda
detects passive paths to the SAN which return no partition table.

This is the relevant part of ks.cfg:
 bootloader --location=mbr --append="rhgb quiet" --driveorder=cciss/c0d0,sda,hda
 [...]
 clearpart --all --drives=cciss/c0d0
 part /boot --fstype "ext3" --size=100 --ondisk=cciss/c0d0
 part pv.42 --size=0 --grow --ondisk=cciss/c0d0
 volgroup systemzs08 --pesize=32768 pv.42
 logvol / --fstype ext3 --name=root --vgname=systemzs08 --size=1024 --grow
 logvol swap --fstype swap --name=swap --vgname=systemzs08 --size=1000 --grow 
 --maxsize=2000

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.Create a kickstart file for a SAN-attached node
2.Try to kickstart-install the node
3.
  
Actual results:
The installation halts with a prompt about /dev/sda and /dev/sdb not having a
partition table and whether they should get one.

Expected results:
The kickstart installation should continue regardless of the state of other
devices not used for installation.

Additional info:
This does not happen on FC4 with a SATA system disk on sda, and the faulty paths
beginning at sdb (here we use a Compaq Smart Array, and sda is the first faulty
path)
Comment 1 Axel Thimm 2005-07-22 09:15:17 EDT
It looks like FC4 does not trigger the bug because it doesn't see the SAN
devices at anaconda time.

What makes it even worse is that the non-faulty paths are now carrying a gpt
table. Now anaconda needs 4 (!) prompts during kickstart time for *each* device.
E.g. for 5 devices on the SAN the kickstart process gets interrupted 20 times.

Is there a way to communicate to anaconda not to look at any other block devices
other than those given for the installation?
Comment 2 Jeremy Katz 2005-07-26 00:10:50 EDT
There's an ignoredisk directive to ignore specific disks.
Comment 3 Axel Thimm 2005-07-26 19:32:29 EDT
Thanks, I found the syntax as

ignoredisk --drives=<drive1>,<drive2>,...

where <driveN> is one of sda,sdb,...,hda,... etc.

But it only works if --initlabel (in clearpart) is not used. If it is used, then
initAll is set which reenables probing for all disks in DiskSet.skippedDisks.

Should I open a new bug for this one?

Note You need to log in before you can comment on or make changes to this bug.