Bug 163913 - Update to 2.6.12-1.1372_FC3-x86_64 kernel missing modules 'build' directory
Update to 2.6.12-1.1372_FC3-x86_64 kernel missing modules 'build' directory
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-21 17:52 EDT by Philip Prindeville
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-21 17:56:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Prindeville 2005-07-21 17:52:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
An automated update (thanks to yum) happened, but when I looked at:

[root@media ~]# ls -ld /lib/modules/*/build
drwxr-xr-x  18 root root 4096 Jul 11 19:54 /lib/modules/2.6.11-1.35_FC3/build
lrwxrwxrwx   1 root root   49 Jul 20 16:35 /lib/modules/2.6.12-1.1372_FC3/build -> ../../../usr/src/kernels/2.6.12-1.1372_FC3-x86_64
[root@media ~]#

it seems that "build" directory in 2.6.12-1.1372 wasn't bundled correctly (as if a copy was done with -d).

This causes various things to fail, including rebuilding the NVidia binary drivers' kernel interface.





Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1372

How reproducible:
Always

Steps to Reproduce:
1. Update kernel on FC3 to 2.6.12-1.1372.
2.
3.
  

Actual Results:  The update succeeded, but the contents of /lib/modules/2.6.12-1.1372_FC3/build are missing (the symlink points to a non-existent directory tree).


Expected Results:  The "build" directory should have been an actual directory (instead of a symlink) and had the appropriate contents.


Additional info:
Comment 1 Jack Aboutboul 2005-07-21 17:56:31 EDT
This is not a bug.  For building external modules that are not part of the stock
kernel please install the properly named/numbered kernel-devel package for your
current kernel.  The information on how to do this in the release notes is
erroneous and it will be taken care of.

Note You need to log in before you can comment on or make changes to this bug.