Bug 1639155 - Touchpad doesn't work on Fedora (LENOVO 330-15IGM)
Summary: Touchpad doesn't work on Fedora (LENOVO 330-15IGM)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-15 07:54 UTC by Denis Karpovskiy
Modified: 2018-11-27 17:12 UTC (History)
16 users (show)

Fixed In Version: kernel-4.19.3-300.fc29 kernel-4.19.3-200.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-24 02:28:37 UTC
Type: Bug


Attachments (Terms of Use)
dmesg on Fedora 29 - touchpad doesn't work (58.30 KB, text/plain)
2018-11-15 21:33 UTC, Denis Karpovskiy
no flags Details
dmesg on openSUSE Tumbleweed - touchpad works perfectly. (79.54 KB, text/plain)
2018-11-15 21:34 UTC, Denis Karpovskiy
no flags Details
Fedora 29 dmesg with 4.19 kernel - still doesn't work (73.07 KB, text/plain)
2018-11-20 08:40 UTC, Denis Karpovskiy
no flags Details

Description Denis Karpovskiy 2018-10-15 07:54:23 UTC
Description of problem:
Whenever I try to use Fedora I notice that touchpad doesn't work. I've tested it on Fedora 28 with 4.17 and 4.18 kernel and Fedora 29 Beta.
An important note is that touchpad works just fine on Ubuntu (with mainline kernel) or openSUSE (Tumbleweed) with kernel version 4.18+.

Version-Release number of selected component (if applicable):
4.17, 4.18

Steps to Reproduce:
1. Boot into installation media of Fedora 28/29 Beta.

Actual results:
Touchpad doesn't work

Expected results:
Working touchpad

Additional info:
I don't know which logs I should attach so I will attach them on demand.
Laptop model: LENOVO Ideapad 330-15IGM

Comment 1 Denis Karpovskiy 2018-11-15 17:27:57 UTC
Still doesn't work in Fedora 29. Also tried 4.19 vanilla kernel and Rawhide with 4.20-rc0 kernel. 

In "dmesg" I can see there 2 hints about the touchpad model: SYNA2B48 and ELAN061C. Idk which of the 2, but I think it is Synaptics because that's what shows me my Windows 10 installation.

I've found that touchpad doesn't work on Ubuntu with mainline kernel 4.17.2 and works on 4.17.3 kernel.

Comment 2 Denis Karpovskiy 2018-11-15 21:32:13 UTC
An entry in /proc/bus/input/devices on openSUSE with working touchpad:
I: Bus=0018 Vendor=06cb Product=8251 Version=0100
N: Name="Synaptics TM3336-001"
P: Phys=i2c-SYNA2B48:00
S: Sysfs=/devices/pci0000:00/0000:00:17.3/i2c_designware.1/i2c-7/i2c-SYNA2B48:00/0018:06CB:8251.0001/input/input16
U: Uniq=
H: Handlers=mouse0 event7 
B: PROP=5
B: EV=b
B: KEY=e520 10000 0 0 0 0
B: ABS=6f3800001000003

Comment 3 Denis Karpovskiy 2018-11-15 21:33:53 UTC
Created attachment 1506283 [details]
dmesg on Fedora 29 - touchpad doesn't work

Comment 4 Denis Karpovskiy 2018-11-15 21:34:51 UTC
Created attachment 1506284 [details]
dmesg on openSUSE Tumbleweed - touchpad works perfectly.

Comment 5 Hans de Goede 2018-11-19 21:53:36 UTC
The opensuse dmesg is done using a 4.19 kernel. We've a 4.19 kernel for Fedora in updates-testing now, can you give that a try ?

Comment 6 Denis Karpovskiy 2018-11-19 22:24:44 UTC
Sure. I just need some time to download, install it and update. I'll post another dmesg log in case it still doesn't work.

Comment 7 Denis Karpovskiy 2018-11-20 08:40:03 UTC
Created attachment 1507365 [details]
Fedora 29 dmesg with 4.19 kernel - still doesn't work

Comment 8 Hans de Goede 2018-11-20 11:00:44 UTC
Ok, I think I know what the problem is now.

I've started a scratch-build of a kernel with some changes added which should fix this, this is currently building here:

https://koji.fedoraproject.org/koji/taskinfo?taskID=31015962

Once this is done building (this takes a couple of hours) please follow these instructions to install and test the kernel and let us know if this fixes things:

https://fedorapeople.org/~jwrdegoede/kernel-test-instructions.txt

Comment 9 Hans de Goede 2018-11-20 11:04:32 UTC
Note that since this is a scratch-build it is not signed, so you need to disable secure-boot if you have it enabled.

Comment 10 Denis Karpovskiy 2018-11-20 14:40:41 UTC
Wow, it works now! But how? What was the problem? My touchpad also doesn't work on Solus (and possibly on other distros, but I haven't checked), so it would be great to port the patch to it.
All keys are fully-functioning, everything is perfect.

Comment 11 Hans de Goede 2018-11-20 14:53:56 UTC
(In reply to Denis Karpovskiy from comment #10)
> Wow, it works now! But how? What was the problem? My touchpad also doesn't
> work on Solus (and possibly on other distros, but I haven't checked), so it
> would be great to port the patch to it.
> All keys are fully-functioning, everything is perfect.

That is good to hear, the next official Fedora kernel build will also include the fix, after which this bug will be closed once that build hits the stable updates repository.

As for what I changed after googling your model to find info on the CPU I noticed it was a Gemini-Lake CPU (I was wondering if your model maybe used an AMD CPU).

After that all I did was enable the CONFIG_PINCTRL_GEMINILAKE kernel option :)

Comment 12 Denis Karpovskiy 2018-11-20 15:54:49 UTC
I've been struggling with the problem for several months and you just enabled the kernel option so now touchpad works. Big thanks! I really appreciate your work.

Comment 13 Fedora Update System 2018-11-21 20:41:47 UTC
kernel-tools-4.19.3-300.fc29 kernel-4.19.3-300.fc29 kernel-headers-4.19.3-300.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-367d08ef69

Comment 14 Fedora Update System 2018-11-21 20:44:39 UTC
kernel-headers-4.19.3-200.fc28 kernel-tools-4.19.3-200.fc28 kernel-4.19.3-200.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7cf713da0d

Comment 15 Fedora Update System 2018-11-22 04:30:31 UTC
kernel-4.19.3-200.fc28, kernel-headers-4.19.3-200.fc28, kernel-tools-4.19.3-200.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7cf713da0d

Comment 16 Fedora Update System 2018-11-22 05:38:57 UTC
kernel-4.19.3-300.fc29, kernel-headers-4.19.3-300.fc29, kernel-tools-4.19.3-300.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-367d08ef69

Comment 17 Fedora Update System 2018-11-24 02:28:37 UTC
kernel-4.19.3-300.fc29, kernel-headers-4.19.3-300.fc29, kernel-tools-4.19.3-300.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2018-11-27 17:12:35 UTC
kernel-4.19.3-200.fc28, kernel-headers-4.19.3-200.fc28, kernel-tools-4.19.3-200.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.