Bug 163917 - kernel 2.6.12-1.1372 fails to boot
kernel 2.6.12-1.1372 fails to boot
Status: CLOSED DUPLICATE of bug 163407
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-21 19:00 EDT by i.goyret
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 02:21:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description i.goyret 2005-07-21 19:00:41 EDT
Description of problem:

  kernel 2.6.12-1.1372 fails to boot.
  Without changing anything, kernel 2.6.11-1.35 boots perfectly fine.

  Both the SMP and UP versions of the kernel were tested and both
  failed. Only the SMP output was captured.

Version-Release number of selected component (if applicable):

  2.6.12-1.1372

How reproducible:

  Always.

Steps to Reproduce:
 1. Boot
 2. kernel panics while trying to mount the root partition (ext3).
  
Actual results:

(Manually captured from the SMP kernel boot -- the panic happens too early to be
able to capture it any other way)

...
Loading 3w-xxxx.ko module
Loading jbd.ko module
Loading ext3.ko module
Creating root device
Mounting root filesystem
mount: error 19 mounting ext3
mount: error 2 mounting none
Switching to new root
Switchroot: mount failed 22
umount /initrd/dev failed: 2
kernel panic - not syncing: Attempted to kill init!
 [<c0120e85>] panic+0x42/0x1ca
 [<c0121ff1>] profile_task_exit+0x31/0x45
 [<c0123d8d>] do_exit+0x252/0x35a
 [<c0123eb5>] next_thread+0x0/0xc
 [<c0103fd9>] syscall_call+0x7/0xb


Expected results:

  Normal boot sequence.

Additional info:

* The same failure occured on two other machines that were updated at the same
time. In all three cases, downgrading to 2.6.11-1.35 allowed the machines to
boot normally.

Contents of /proc/cpuinfo:

[root@soda ~]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Xeon(TM) CPU 3.60GHz
stepping        : 1
cpu MHz         : 3601.779
cache size      : 1024 KB
physical id     : 0
siblings        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm pni monitor
ds_cpl est tm2 cid cx16 xtpr
bogomips        : 7143.42

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Xeon(TM) CPU 3.60GHz
stepping        : 1
cpu MHz         : 3601.779
cache size      : 1024 KB
physical id     : 0
siblings        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm pni monitor
ds_cpl est tm2 cid cx16 xtpr
bogomips        : 7192.57

processor       : 2
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Xeon(TM) CPU 3.60GHz
stepping        : 1
cpu MHz         : 3601.779
cache size      : 1024 KB
physical id     : 3
siblings        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm pni monitor
ds_cpl est tm2 cid cx16 xtpr
bogomips        : 7192.57

processor       : 3
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Xeon(TM) CPU 3.60GHz
stepping        : 1
cpu MHz         : 3601.779
cache size      : 1024 KB
physical id     : 3
siblings        : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm pni monitor
ds_cpl est tm2 cid cx16 xtpr
bogomips        : 7192.57

[root@soda ~]#
Comment 1 Dave Jones 2005-07-28 02:21:57 EDT

*** This bug has been marked as a duplicate of 163407 ***

Note You need to log in before you can comment on or make changes to this bug.