Bug 16392 - rpm-3.0.5-9.6x fails to build kernel-2.2.16-3.src.rpm
rpm-3.0.5-9.6x fails to build kernel-2.2.16-3.src.rpm
Status: CLOSED DUPLICATE of bug 14463
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Depends On:
  Show dependency treegraph
Reported: 2000-08-16 15:46 EDT by Jan Carlson
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-08-16 15:46:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jan Carlson 2000-08-16 15:46:32 EDT
This is RH6.2 with all official updates applied as of today, Aug 16, 2000.

The updated rpm-3.0.5-9.6x from the "URL" fails parsing 
spec file from kernel-2.2.16-3.src.rpm.
The original RH6.2 rpm-3.0.4-0.48.i386.rpm had no trouble.

# rpm -bp kernel-2.2.16.spec
parse error in expression
/home/src/redhat/SPECS/kernel-2.2.16.spec:16: parseExpressionBoolean
returns -1

# head -16 kernel-2.2.16.spec
Summary: The Linux kernel (the core of the Linux operating system).
Name: kernel
%define sublevel 16
%define kversion 2.2.%{sublevel}
%define pcmciaver 3.1.8
%define ibcsver 2.1-981105
%define ksymoopsver 0.7c
# disable build root strip policy
%define __spec_install_post /usr/lib/rpm/brp-compress || :
# define lfs as either 0 (for off) or 1 (for on) when making the kernel
%define subrelease 3
%define lfs 0
%define ext3 0
Version: %{kversion}
%if %{lfs}
%if %{ext3}                                 #### line 16 ####
Comment 1 Jeff Johnson 2000-08-16 16:18:47 EDT

*** This bug has been marked as a duplicate of 14463 ***

Note You need to log in before you can comment on or make changes to this bug.