Bug 163921 - kickstart install creates incorrect labels by appending a trailing "1"
kickstart install creates incorrect labels by appending a trailing "1"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-07-21 19:53 EDT by Ignacio G.
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:36:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ignacio G. 2005-07-21 19:53:16 EDT
I'm not sure if this related to anaconda or some other component. Please advise.

Description of problem:

I installed FC3 on 14 systems using kickstart installation over NFS.
In every single case, the installation created disk labels with a random "1"
attached to the end of it.

For example, a system "soda" was created with these statements in the
kickstart file:

...
install
nfs --server=192.168.127.200  --dir=/export/fedora-core/3
zerombr yes
clearpart --all --initlabel

# Disk partitioning information
part /boot --fstype ext3 --size 250 --ondisk sda
part / --fstype ext3 --size 20480 --ondisk sda
part swap --size 16384 --ondisk sda
part /disk1 --fstype ext3 --size 1 --grow --ondisk=sda

...

But /etc/fstab was created with these entries:
[root@soda ~]# grep LABEL /etc/fstab
LABEL=/1                /                       ext3    defaults        1 1
LABEL=/boot1            /boot                   ext3    defaults        1 2
LABEL=/disk11           /disk1                  ext3    defaults        1 2
LABEL=SWAP-sda3         swap                    swap    defaults        0 0
[root@soda ~]#

Observe the extra "1" on "/", "/boot" and "/disk1".

This extra character is also visible during boot up:

/1: clean, 151906/2626560 files, 792774/5242880 blocks
 ^
Checking root filesystem succeeded
Remounting root filesystem in read-write mode:  succeeded
No volume groups found
Setting up Logical Volume Management: succeeded
/boot1: clean, 52/64256 files, 31131/257008 blocks
     ^

On a different machine, with this kickstart statements:

# Disk partitioning information
part /boot --fstype ext3 --size 250 --ondisk sda
part / --fstype ext3 --size 20480 --ondisk sda
part swap --size 16384 --ondisk sdb
part /disk1 --fstype ext3 --size 1 --grow --ondisk=sda
part /disk2 --fstype ext3 --size 1 --grow --ondisk=sdb
part /disk3 --fstype ext3 --size 1 --grow --ondisk=sdc
part /disk4 --fstype ext3 --size 1 --grow --ondisk=sdd

The labels came out to be:
LABEL=/1                /                       ext3    defaults        1 1
LABEL=/boot1            /boot                   ext3    defaults        1 2
LABEL=/disk11           /disk1                  ext3    defaults        1 2
LABEL=/disk2            /disk2                  ext3    defaults        1 2
LABEL=/disk31           /disk3                  ext3    defaults        1 2
LABEL=/disk41           /disk4                  ext3    defaults        1 2

Note that /disk2 was set as expected.

The machines work fine otherwise, but the labelling is very confusing.


How reproducible:

It seemed to happened very systematically since it happened on all 14 systems,
and some of them were installed more than once (due to some fine tuning). The
above odd label names happened every time.


Steps to Reproduce:
1. create kickstart file
2. boot target system with FC3 disk1 CD, enter "linux ks" at the prompt.
3. after the system is installed, check /etc/fstab.

Actual results:  Shown above. A random "1" is appended to the LABEL=.

Expected results: The labels assigned to each partition should not have random
"1" appended.
Comment 1 Chris Lumens 2005-10-05 13:36:24 EDT
I believe this is fixed in Rawhide.  Please test with FC5test1 when it comes out
and verify.  Feel free to reopen if you are still experiencing this problem at
that time.

Note You need to log in before you can comment on or make changes to this bug.