Bug 163932 - Grub does not load system boots right into XP with no FC4 boot option (XP on hda and FC4 on hdb)
Grub does not load system boots right into XP with no FC4 boot option (XP on ...
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-07-21 22:58 EDT by Nathan M
Modified: 2008-02-19 19:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-19 19:25:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nathan M 2005-07-21 22:58:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
I am experiencing the exact same issue as "duralisis" describes in detail at http://forums.fedoraforum.org/archive/index.php/t-51741.html.  I've tried the same fix attempts as duralist tried with the same unsuccessfull results (booting grub on different drives, etc...).

My Configuration is:
Dell Dimension 8100
hda 40GB IDE with NTLDR XP Pro SP2
hdb 20GB IDE with FC4

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install FC on 20GB HD (hdb)
2. Tell Installer to put GRUB on hda MBR
3. Reboot

Actual Results:  System goes straight into XP without loading GRUB

Expected Results:  Grub should have prompted to boot into XP or FC4

Additional info:

Configuring NTLDR to allow booting to FC4 on hdb using bootpart in Windows does not allow booting of FC4 either.  See:

I've tried reinstalling FC4 entirely (no change in error), I tried changing the bootloader settings using the recover mode and update installation tools, this gave a Kernel error and said no changes could be made to the bootloader configuration (can't remember the exact message).
Comment 1 Nathan M 2005-07-21 23:08:18 EDT
The directions I initally had followed can be found at:
I followed these directions verbatim and still had problems when I selected 
Linux from the list.  I then tried installing Grub to use as a bootloader 
instead of NTLDR on hda.  This resulted in the system booting straight to XP 
with no Grub prompt for selecting FC4.
Comment 2 Nathan M 2005-07-22 15:16:58 EDT
I just wanted to also note that the 40GB hda is formated with NTFS.  This may 
be relavent.
Comment 3 Nathan M 2005-07-25 03:06:32 EDT
I have found a work around for this issue on my configuration:

I first booted to the recover console from the first Fedora Core 4 CD opened
"grub" and entered the commands as follows:

# grub
grub> root (hd1,0) (since fedora /boot is on /hdb)
grub> setup (hd0) (still the mbr of the first hd)
grub> quit

Next rebooting the system gave the grub boot prompt, problem solved.  This is
deffinatley still a bug in the FC 4 installer in that this is not automatically
configured as it should be (or as the install wizard suggests).
Comment 4 Christian Iseli 2007-01-22 05:53:39 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 5 petrosyan 2008-02-19 19:25:23 EST
Fedora Core 4 is no longer maintained.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.

Note You need to log in before you can comment on or make changes to this bug.