Bug 163943 - yum groupinstall "GNOME Desktop Environment" doesn't install X
yum groupinstall "GNOME Desktop Environment" doesn't install X
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-22 04:46 EDT by Need Real Name
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 16:16:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-07-22 04:46:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.6.1

Description of problem:
This confused me, it might not be a bug.

After running a minimal install of FC4, I ran yum grouplist.
yum showed a list of groups of software I could install (note: some items were duplicated).

I wanted to get to a working Gnome setup, so I ran
 yum groupinstall "GNOME Desktop Environment"
This didn't install X-Windows.

Next, I ran
 yum groupinstall "X Window System"

This didn't do it either. So I ran:
 yum install xorg-x11

I expect the order I did this was the problem, but should xorg-x11 not be installed by "X Window System"?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Seth Vidal 2005-07-22 09:03:10 EDT
what did the first command say it was going to install?
Comment 2 Need Real Name 2005-07-22 09:06:53 EDT
(In reply to comment #1)
> what did the first command say it was going to install?

The "GNOME Desktop Environment".

I would expect to be able to use the GNOME Desktop Environment after installing
this, but couldn't.
Comment 3 Seth Vidal 2005-07-22 09:12:52 EDT
no, I mean when you ran that command yum said it was installing certain
packages, what packages did it say it would install?
Comment 4 Need Real Name 2005-07-22 09:21:30 EDT
I'm sorry, I don't have the output for that.

I'd try again if I could, bug since Xen isn't working for me (bug 158367), I'm
afraid I can't.
Comment 5 Seth Vidal 2005-07-22 09:29:23 EDT
okay well that makes this hard to diagnose but here's what i'm guessing.

B/c you had minimal installed you had the X window libs installed but not the
binaries for starting X and the binaries for X are probably not directly
required by anything in gnome.

until I get some more info I can't help all that much.
Comment 6 Jeremy Katz 2005-09-21 15:13:08 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further information, feel free to
add to the report and reopen.
Comment 7 Need Real Name 2005-09-21 18:03:40 EDT
Oh come on - bug bug 158367 has only just been marked fixed, and I haven't had 
time to retest.
Give me a couple of weeks.
Comment 8 Jeremy Katz 2005-09-21 18:14:52 EDT
Sorry, was going through and doing some mass closing of NEEDINFO bugs to clean
up my bug list and get rid of some cruft.  So, definitely, go for it :)
Comment 9 Need Real Name 2005-10-14 08:41:20 EDT
Hm. Xen is still broken (for me), so I can't retest this.

I'd like to keep this bug on my buglist, but I understand that you want it off
yours. Would assigning the bug to me fix that?
Comment 10 Jeremy Katz 2005-10-14 10:43:38 EDT
I'll just bump back to NEEDINFO_REPORTER.  
Comment 11 Jeremy Katz 2006-04-26 16:16:58 EDT
I'm pretty sure Seth is right about what's going on here and that's the expected
behavior.

Note You need to log in before you can comment on or make changes to this bug.