Bug 1639599 - Improve support-ability of glusterfs
Summary: Improve support-ability of glusterfs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-16 07:47 UTC by Amar Tumballi
Modified: 2019-03-25 16:31 UTC (History)
4 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 16:31:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21509 0 None Open mem-pool: change the values to 64bits 2018-11-01 02:39:19 UTC

Description Amar Tumballi 2018-10-16 07:47:20 UTC
Description of problem:
There are many small improvements possible in GlusterFS, which would help people to support the project better, when used in their production system.

It may include changes in logs, changes in some statedump messages, changes in sos, or more automated validations of higher latency etc etc.

To start with, wherever possible, we can log string, instead of 'enum' value, for example, fops.

Version-Release number of selected component (if applicable):
master


Expected results:
A product which can be managed by not-so-expert sys-admin!

Additional info:
This would be a Blanket bug used for all such improvements!

Comment 1 Worker Ant 2018-10-16 07:57:15 UTC
REVIEW: https://review.gluster.org/21425 (server-protocol: set the frame type to TYPE_FOP) posted (#1) for review on master by Amar Tumballi

Comment 2 Worker Ant 2018-10-29 08:57:14 UTC
COMMIT: https://review.gluster.org/21425 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- server-protocol: set the frame type to TYPE_FOP

This will allow proper printing of exact 'fop' type to be logged in
string, not number, during backtraces.

Considering this was not done on brick processes, we have no easy
way to glance and understand which fops were pending.

What gets changed:

After a crash, most of the core-dumps logged were of the form:
```
pending frames:
frame : type(0) op(18)
frame : type(0) op(18)
frame : type(0) op(28)
```
would change to
```
pending frames:
frame : type(1) op(SETXATTR)
frame : type(1) op(SETXATTR)
frame : type(1) op(READDIR)
```

updates: bz#1639599
Change-Id: I0e3d2a8dee9cfde7ed0112a948f5213f546efb80
Signed-off-by: Amar Tumballi <amarts@redhat.com>

Comment 3 Worker Ant 2018-10-30 06:24:29 UTC
REVIEW: https://review.gluster.org/21509 (mem-pool: change the values to 64bits) posted (#1) for review on master by Amar Tumballi

Comment 4 Worker Ant 2018-11-01 02:39:17 UTC
REVIEW: https://review.gluster.org/21509 (mem-pool: change the values to 64bits) posted (#4) for review on master by Amar Tumballi

Comment 5 Shyamsundar 2019-03-25 16:31:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.