Bug 1639636 - github handler script doesn't handle unicode
Summary: github handler script doesn't handle unicode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nigel Babu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-16 09:20 UTC by Amar Tumballi
Modified: 2018-10-16 12:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-16 12:08:53 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amar Tumballi 2018-10-16 09:20:38 UTC
Description of problem:
Check https://build.gluster.org/job/comment-on-issue/10145/console & https://review.gluster.org/21426/... It couldn't parse Pattrick's full name.

Version-Release number of selected component (if applicable):
master

How reproducible:
100%

Steps to Reproduce:
1. Submit a patch with unicode content!
2. Watch the job fail!



Additional info:
This is assumed by the traceback from the job output.. I may be wrong!

Comment 1 Nigel Babu 2018-10-16 09:37:47 UTC
Huh. There's even a test to ensure that unicode compatibility works. I'll take a look

Comment 2 M. Scherer 2018-10-16 09:57:36 UTC
I bet the issue is that jenkins run with the C locale. 

Since we did faced issue in the past with locale (like locale leaking to process and so pattern matching breaking as jenkins locales were set to french after I restarted it), the move to systemd prevented that to happen (systemd when we upgraded to EL 7).

Comment 3 Nigel Babu 2018-10-16 12:08:29 UTC
subprocess always returns a bytestring that needs to be encoded. Fixed in https://github.com/gluster/glusterfs-patch-acceptance-tests/commit/abf6e97911ffd0ed3b85adbb86fb7ccfc6059235 and deployed.


Note You need to log in before you can comment on or make changes to this bug.