Bug 1639640 - Biber and texlive-biblatex versions are incompatible
Summary: Biber and texlive-biblatex versions are incompatible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: biber
Version: 29
Hardware: All
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: Colin Macdonald
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1401482
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-16 09:29 UTC by flohri
Modified: 2018-10-30 17:29 UTC (History)
7 users (show)

Fixed In Version: biber-2.11-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 17:29:54 UTC
Type: Bug


Attachments (Terms of Use)

Description flohri 2018-10-16 09:29:42 UTC
Description of problem:
The official biber package is of version 2.7 while texlive-biblatex is of version 3.11. They are closely coupled to each other, so biber needs an update to current version 2.11 to work with current texlive-biblatex package.

Version-Release number of selected component (if applicable):
2.7

Steps to Reproduce:
1. Install biber (2.7)
2. Install texlive-biblatex (3.11)
3. Try to create a bibliography of a document with biber

Actual results:
...
Error: Found biblatex control file version 3.4, expected version 3.3.
This means that your biber (2.7) and biblatex (3.11) versions are incompatible.
...

Expected results:
a clean run of biber

This is my first filed bug. Please excuse my bad term

Comment 1 Ankur Sinha (FranciscoD) 2018-10-16 10:28:27 UTC
Seeing this too. I reckon biber needs an update, and that should hopefully fix it. Increasing severity, since currently, biber will not work with biblatex.

$ rpm -q biber
biber-2.7-3.fc29.noarch
$ rpm -qa \*biblatex\*
texlive-biblatex-nature-svn43382-20.fc29.noarch
texlive-biblatex-svn46851-20.fc29.noarch

Comment 3 Fedora Update System 2018-10-18 20:09:55 UTC
biber-2.11-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-129b020cb7

Comment 4 Colin Macdonald 2018-10-18 20:11:55 UTC
Please test and send karma for F29

Comment 5 Fedora Update System 2018-10-20 19:23:29 UTC
biber-2.11-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-129b020cb7

Comment 6 Fedora Update System 2018-10-30 17:29:54 UTC
biber-2.11-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.