Bug 1639765 - Rock960 hangs after boot
Summary: Rock960 hangs after boot
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Keywords:
Depends On:
Blocks: ARMTracker IoT F29FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-10-16 14:32 UTC by Manivannan Sadhasivam
Modified: 2018-10-23 15:04 UTC (History)
19 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-10-23 15:04:15 UTC


Attachments (Terms of Use)

Description Manivannan Sadhasivam 2018-10-16 14:32:49 UTC
Description of problem:

When booted with F29, Rock960 board hangs roughly after 1 minute.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Manivannan Sadhasivam 2018-10-16 14:33:41 UTC
This can be fixed with the below patch:

https://lore.kernel.org/patchwork/patch/1000432/

Comment 2 Peter Robinson 2018-10-17 14:33:43 UTC
This will be in the next kernel build

Comment 3 Peter Robinson 2018-10-22 07:25:48 UTC
Fixed in build kernel-4.18.16-300.fc29

Comment 4 Fedora Blocker Bugs Application 2018-10-22 07:25:57 UTC
Proposed as a Freeze Exception for 29-final by Fedora user pbrobinson using the blocker tracking app because:

 Rock960 is a Fedora IoT reference device

Comment 5 Fedora Update System 2018-10-22 08:36:23 UTC
kernel-4.18.16-300.fc29 kernel-headers-4.18.16-300.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-dbea673f8a

Comment 6 František Zatloukal 2018-10-22 16:51:07 UTC
Discussed during the 2018-10-22 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made:

"This bug has been noted to be a "nice-to-have" fix, so we accept it as an AcceptedFreezeException"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-10-22/f29-blocker-review.2018-10-22-16.00.log.txt

Comment 7 Fedora Update System 2018-10-22 19:23:40 UTC
kernel-4.18.16-300.fc29, kernel-headers-4.18.16-300.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-dbea673f8a

Comment 8 Fedora Update System 2018-10-23 15:04:15 UTC
kernel-4.18.16-300.fc29, kernel-headers-4.18.16-300.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.