Bug 163983 - Gnome login as root fails
Gnome login as root fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnome-session (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-22 12:28 EDT by R. James Cross, Jr.
Modified: 2012-06-20 12:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 12:09:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R. James Cross, Jr. 2005-07-22 12:28:51 EDT
Description of problem: Root login with gnome fails. It works with KDE as root 
and as an ordinary user with gnome.


Version-Release number of selected component (if applicable):
updated as of yesterday

How reproducible: Every time as of this morning. It worked yesterday


Steps to Reproduce:
1. Log in as root 
2.
3.
  
Actual results: Red Hat Enterprise Linux Logo appears, and nothing else. There 
are no error messages. To get out I must log in remotely and kill the gnome 
process.


Expected results: Login


Additional info: I recently upgraded from EL 3 to EL 4. I have logged in 
several times as root, and then it stopped. How can I rebuild the gnome 
configuration files for root.
Comment 1 Ray Strode [halfline] 2005-07-25 10:32:28 EDT
if you move ~root/.gnome2/session to ~root/.gnome2/session.backup
and log in, does your problem go away?
Comment 2 R. James Cross, Jr. 2005-07-25 11:05:50 EDT
I tried that and it still failed. I tried to install additional packages for 
both KDE and gnome. Rpm wouldn't install them because certain libraries were 
not installed. Rpm didn't tell me which pacage(s) included the libraries, so I 
could not continue. It now seems obvious that the upgrade from EL 3 to EL4 
fails to install key components, leaving a "bastard" system that is not 
entirely functional. I also found that SELinux is not properly installed. 
There are no configuration files, and the menue in the security tool is gray. 
Sound doesn't work, and pop3s failed because dovecot was not installed. I have 
reluctantly concluded that I must do a clean install and hope that I can 
restore all the user and other files. Did you people actually test the upgrade 
from EL 3??? This is now the third time that I have been burned by upgrading a 
Red Hat system, only to find that it really didn't work.
Comment 3 Matěj Cepl 2008-03-06 06:41:58 EST
Is this bug relevant anymore? I thought we officially don't support using X as
root, do we?
Comment 4 Jiri Pallich 2012-06-20 12:09:39 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.