Bug 16399 - Startup does not properly handle multiple Virtual Servers
Startup does not properly handle multiple Virtual Servers
Status: CLOSED ERRATA
Product: Red Hat High Availability Server
Classification: Retired
Component: piranha (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Phil Copeland
Phil Copeland
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-16 17:22 EDT by keith.moore
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-16 19:28:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LVS Configuration (954 bytes, text/plain)
2000-08-16 17:25 EDT, keith.moore
no flags Details
Updated Configuration (1007 bytes, text/plain)
2000-08-16 17:54 EDT, keith.moore
no flags Details
Patch for lvs.c bug with persistence (600 bytes, patch)
2000-08-16 19:19 EDT, keith.moore
no flags Details | Diff

  None (edit)
Description Red Hat Bugzilla 2000-08-16 17:22:47 EDT
I have piranha-0.4.16-3 installed (Including all the appropriate Kernal
updates) and the configuration reader seems to be having a major problem
with multiple virtual servers.

I have a configuration using NAT for 1 Site, but the site has both port 80
and 443.

I have virtual servers VS1:80 and VS1:443 each has 2 real servers (Same
ones for each).

I ran it with pulse -v and it brings up the first one fine, then it states:

Aug 16 16:07:17 rrbwebfarm2 lvs[1876]: starting virtual service VS1 active:
443     

But it never runs the proper ipvsadm commands to bring up the services.  If
I manually run all the commands everything works fine. (ipvsadm, ifconfig,
etc).

No nanny's get kicked off for the second site either.  The only two running
nanny processes are for the first virtual site.

If I switch the order of the Virtual servers in the configuration file,
lvs.cf, it switches which one comes up, so neither one has a configuration
issue for the virtual server definition.

ipvsadm -l does not show the second VS at all.

-- Keith Moore
Comment 1 Red Hat Bugzilla 2000-08-16 17:25:16 EDT
Created attachment 2576 [details]
LVS Configuration
Comment 2 Red Hat Bugzilla 2000-08-16 17:43:17 EDT
Try using 2 different virtual IP addresses and devices. The virtual services as
they are defined are using the same address and device. Services have to be
individualized by ip address.
Comment 3 Red Hat Bugzilla 2000-08-16 17:48:57 EDT
After reading all previous piranha bug reports I rebuilt configuration using web
tool. I had made 1 minor change by hand, and want to insure that this was not
causing the problem.  The problem still persists.  Attached is the updated
config.

-- Keith
Comment 4 Red Hat Bugzilla 2000-08-16 17:53:29 EDT
Below is the updated config, created with the web tool, and with the change
requested by Keith (The other one).  It still only brings up one site.  I have
this working on the 6.0 version of the LVS (1 IP, 2 different ports).  and it
appeared to have worked once with the latest software, but when I added the
second REAL servers to each Virtual server, it started doing this to me (I used
the web tool for the config changes).  I can't get back to where it worked
originally.  

-- Keith
Comment 5 Red Hat Bugzilla 2000-08-16 17:54:17 EDT
Created attachment 2578 [details]
Updated Configuration
Comment 6 Red Hat Bugzilla 2000-08-16 18:07:21 EDT
When I updated it with 2 different IPs for the virtual services, the Virtual
Interface is brought up, just no ipvsadm commands are run to configure the
routing.

I completely zeroed the /etc/lvs.cf and rebuilt it from scratch using the Web
tool, still same issue.

Based on what I see in the code, it uses the IP+Port as the Service Identifier,
so it shouldn't have a problem with the same IP twice, but different ports.

-- Keith
Comment 7 Red Hat Bugzilla 2000-08-16 18:51:31 EDT
OK. I'll check this out in the lab.
Comment 8 Red Hat Bugzilla 2000-08-16 19:09:31 EDT
*** Bug 16316 has been marked as a duplicate of this bug. ***
Comment 9 Red Hat Bugzilla 2000-08-16 19:18:30 EDT
I found that my problem is different than the other bug.  I found a bug with
persistence.  I updated the code and my is fully functional now, even with the
same IPs.  I will attach my patch.

-- Keith
Comment 10 Red Hat Bugzilla 2000-08-16 19:19:16 EDT
Created attachment 2580 [details]
Patch for lvs.c bug with persistence
Comment 11 Red Hat Bugzilla 2000-08-16 19:23:55 EDT
Thanks! Nice patch. It'll be included.

Are you saying that your LVS problem has now been fixed because of this?

Comment 12 Red Hat Bugzilla 2000-08-16 19:28:53 EDT
Yes, it is fully functional now.  Also, this same problem may be related to why
sometimes lvs went defunct in other bug reports, and nanny didn't get killed
properly.  I was seeing the same issues until I updated the lvs.c.

Here is an output of my ipvsadm:

[root@rrbwebfarm2 log]# ipvsadm
IP Virtual Server version 0.9.14 (size=4096)
Prot LocalAddress:Port Scheduler Flags
  -> RemoteAddress:Port          Forward Weight ActiveConn InActConn
TCP  198.245.191.240:https wlc persistent 20
  -> renpwwwbkprd6.renp-dmz.com:https Masq    1      0          0
  -> renpwwwbkprd5.renp-dmz.com:https Masq    1      0          0
TCP  198.245.191.240:www wlc persistent 20
  -> renpwwwbkprd6.renp-dmz.com:www Masq    1      0          0
  -> renpwwwbkprd5.renp-dmz.com:www Masq    1      0          0 

-- Keith Moore
Comment 13 Red Hat Bugzilla 2000-08-16 19:45:28 EDT
Thanks again. Your name and patch now appear in the product source and changelog
:-)

A new source RPM should appear shortly in the expermential downlaod area.
Official RPMs will also eventually be posted.

Note You need to log in before you can comment on or make changes to this bug.