Bug 163992 - Cairo-based GTK+ always antialiases fonts
Cairo-based GTK+ always antialiases fonts
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-22 13:47 EDT by Luca Barbieri
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-26 12:50:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luca Barbieri 2005-07-22 13:47:38 EDT
Description of problem:
After upgrading to GTK+ 2.7.0, fontconfig directives specifying that fonts
should not be antialiased are ignored and fonts rendered by GTK+ are always
antialiased.

Version-Release number of selected component (if applicable):
gtk2-2.7.3-1

How reproducible:
Always.

Steps to Reproduce:
1. Modify /etc/fonts/local.conf so that antialias is set to false for all fonts
2. Install GTK+ 2.6.8 and verify that the problem is not present
3. Upgrade to GTK+ 2.7.x

Actual results:
All fonts are antialiased.

Expected results:
Fonts are aliased according to the "antialias" fontconfig property.

Additional info:
Comment 1 Matthias Clasen 2005-07-26 12:50:04 EDT
This will be fixed in the next release, which I'll push as soon as we have a new
cairo.

Note You need to log in before you can comment on or make changes to this bug.