Bug 1639998 - dnf 4 output changes
Summary: dnf 4 output changes
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 1639652 1642375 1643706 (view as bug list)
Depends On:
Blocks: 1649286
TreeView+ depends on / blocked
 
Reported: 2018-10-17 06:45 UTC by Nerijus Baliūnas
Modified: 2018-12-05 02:33 UTC (History)
10 users (show)

(edit)
Clone Of:
: 1649286 (view as bug list)
(edit)
Last Closed: 2018-12-05 02:33:26 UTC


Attachments (Terms of Use)

Description Nerijus Baliūnas 2018-10-17 06:45:21 UTC
With dnf 3.6.1-2.fc29 output was:
# dnf update
  Running scriptlet : geoclue2-2.4.13-1.fc29.x86_64                           7/48 
  Upgrading         : geoclue2-2.4.13-1.fc29.x86_64                           7/48 
  Running scriptlet : geoclue2-2.4.13-1.fc29.x86_64                           7/48 
warning: /etc/geoclue/geoclue.conf saved as /etc/geoclue/geoclue.conf.rpmsave
  Installing        : python3-unbound-1.8.1-1.fc29.x86_64                     8/48 
  Upgrading         : python3-dnf-4.0.4-1.fc29.noarch                         9/48 

It was very easy to see output from rpm about rpmsave, rpmnew files.

With dnf 4.0.4-1.fc29 output is:
# dnf update
Upgrade: libssh-0.8.4-1.fc29.x86_64
Upgrade: geoclue2-2.4.13-1.fc29.x86_64
  Running scriptlet : geoclue2-2.4.13-1.fc29.x86_64                           4/16 
  Upgrading         : geoclue2-2.4.13-1.fc29.x86_64                           4/16 
  Running scriptlet : geoclue2-2.4.13-1.fc29.x86_64                           4/16 
warning: /etc/geoclue/geoclue.conf saved as /etc/geoclue/geoclue.conf.rpmsave

Upgrade: geoclue2-2.4.13-1.fc29.x86_64
Upgrade: geoclue2-libs-2.4.13-1.fc29.x86_64
  Upgrading         : geoclue2-libs-2.4.13-1.fc29.x86_64                      5/16

Now it is more difficult to see info about rpmsave at a quick glance.
Could it be possible to rearrange output like this:

# dnf update
  Upgrade: libssh-0.8.4-1.fc29.x86_64
  Upgrade: geoclue2-2.4.13-1.fc29.x86_64
  Running scriptlet : geoclue2-2.4.13-1.fc29.x86_64                           4/16 
  Upgrading         : geoclue2-2.4.13-1.fc29.x86_64                           4/16 
  Running scriptlet : geoclue2-2.4.13-1.fc29.x86_64                           4/16 
warning: /etc/geoclue/geoclue.conf saved as /etc/geoclue/geoclue.conf.rpmsave

  Upgrade: geoclue2-2.4.13-1.fc29.x86_64
  Upgrade: geoclue2-libs-2.4.13-1.fc29.x86_64
  Upgrading         : geoclue2-libs-2.4.13-1.fc29.x86_64                      5/16

Comment 1 Jaroslav Mracek 2018-10-22 10:59:47 UTC
I created a patch that should solve the issue (https://github.com/rpm-software-management/dnf/pull/1246)

Comment 2 Marek Blaha 2018-10-24 10:20:06 UTC
*** Bug 1642375 has been marked as a duplicate of this bug. ***

Comment 3 Marek Blaha 2018-10-29 06:17:54 UTC
*** Bug 1643706 has been marked as a duplicate of this bug. ***

Comment 4 Tom Hughes 2018-10-31 09:10:02 UTC
*** Bug 1639652 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2018-11-22 18:56:52 UTC
libdnf-0.22.3-1.fc29 dnf-4.0.9-1.fc29 dnf-plugins-core-4.0.2-1.fc29 dnf-plugins-extras-4.0.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-17cbc3c616

Comment 6 Fedora Update System 2018-11-23 02:56:26 UTC
dnf-4.0.9-1.fc29, dnf-plugins-core-4.0.2-1.fc29, dnf-plugins-extras-4.0.0-1.fc29, libdnf-0.22.3-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-17cbc3c616

Comment 7 Fedora Update System 2018-12-05 02:33:26 UTC
dnf-4.0.9-1.fc29, dnf-plugins-core-4.0.2-1.fc29, dnf-plugins-extras-4.0.0-1.fc29, libdnf-0.22.3-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.