Bug 16400 - i2c_viapro.o kernel module is missing
i2c_viapro.o kernel module is missing
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-16 17:32 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-21 16:03:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-16 17:32:38 EDT
When running sensors-detect, the program correctly identifies that the
motherboard is using a VIA chipset:

<snip>
 Do you want to probe now? (YES/no):
Probing for PCI bus adapters...
Use driver `i2c-viapro' for device 00:07.3: VIA Technologies VT 82C596
Apollo ACPI
Probe succesfully concluded.
<snip>

However, the kernel module for i2c-viapro.o is non-existant.  Also, the
source file is not in the kernel tarball in the kernel source RPM.  So it
looks like the lm_sensors patch will need to be added again with the source
file kernel/busses/i2c-viapro.c.

I am using the 2.2.16-17smp kernel.

Regards,

Pat
Comment 1 Glen Foster 2000-08-18 15:31:13 EDT
Michael, we need to understand ASAP if we can fix this for the current release -
thanks.
Comment 2 Michael K. Johnson 2000-08-18 15:36:03 EDT
Yes, Glen, already investigating.
Comment 3 Tim Powers 2000-08-19 09:00:31 EDT
Here is the output from when I ran sensors-detect on my home machine (only the
applicable parts:

Probing for PCI bus adapters...
Use driver `i2c-viapro' for device 00:07.4: VIA Technologies VT 82C686 Apollo
ACPI
Use driver `i2c-voodoo3' for device 01:05.0: 3Dfx Voodoo3
Probe succesfully concluded.

 We will now try to load each adapter module in turn.
Load `i2c-viapro' (say NO if built into your kernel)? (YES/no): YES
modprobe: Can't locate module i2c-viapro
Loading failed ()... skipping.
Load `i2c-voodoo3' (say NO if built into your kernel)? (YES/no): YES
modprobe: Can't locate module i2c-voodoo3
Loading failed ()... skipping.

So it's not just i2c-viapro that's missing, also i2c-voodoo3 is missing.

Tim
Comment 4 Michael K. Johnson 2000-08-21 15:45:08 EDT
i2c_viapro appears to be listed as "complete but untested"
and i2c_voodoo3 as "beta" quality.  This is probably why
they are not included...
Comment 5 Need Real Name 2000-08-21 16:03:32 EDT
If I'm not mistaken, this is a bug report for Redhat 7.0 *BETA*, right? :-)

What better way to test them than to put them in?  Anyhow, I for one would
appreicate that the i2c_viapro.o be put in so that I don't have to re-build
kernel RPMs when 7.0 ships.
Comment 6 Michael K. Johnson 2000-08-21 16:26:47 EDT
We are trying to build a kernel that we can support.  Before we
add modules even to a beta, we want to hear a certain level of
confidence from the authors.

Note You need to log in before you can comment on or make changes to this bug.