Bug 1640018 - [admin] Catalog page will reload automatically after press "Enter" in "Filter by name" field
Summary: [admin] Catalog page will reload automatically after press "Enter" in "Filter...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Jeff Phillips
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-17 07:14 UTC by Yanping Zhang
Modified: 2019-06-04 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:56 UTC

Description Yanping Zhang 2018-10-17 07:14:50 UTC
Description of problem:
On home catalog page, input "php" in "Filter by name" field, then press "Enter", the catalog page will reload automatically and the input text is cleared.

Version-Release number of selected component (if applicable):
registry.reg-aws.openshift.com:443/openshift/ose-console                       v4.0.0-0.20.0.0     f9dc1cabf379        4 days ago          252 MB


How reproducible:
Always

Steps to Reproduce:
1.On home catalog page, input "php" in "Filter by name" field, then press "Enter".
2.
3.

Actual results:
1.The catalog page reloads automatically and the input text is cleared.


Expected results:
1. Should not reload and clear the input text.

Additional info:

Comment 1 Jeff Phillips 2018-10-17 18:16:31 UTC
Fixed by PR https://github.com/openshift/console/pull/664

Comment 2 Jeff Phillips 2018-11-20 11:26:21 UTC
https://github.com/openshift/console/pull/664

Comment 3 Jeff Phillips 2018-11-28 12:17:37 UTC
PR: https://github.com/openshift/console/pull/664

Comment 4 Yanping Zhang 2018-12-20 07:29:18 UTC
Checked on env with console image: registry.svc.ci.openshift.org/openshift/origin-v4.0-2018-12-19-004812@sha256   4a55761c7c1e1b6ada3b671bda54c59a0eef9934ddae4962f8d0c788f174688a   10a46fdc51fb   30 hours ago    268 MB
Now it won't reload the page automatically when press "Enter" in the filter box on catalog page.
The bug has been fixed, so move it to Verified.

Comment 7 errata-xmlrpc 2019-06-04 10:40:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.