Bug 1640023 - Firefox-wayland - copy/paste doens't work
Summary: Firefox-wayland - copy/paste doens't work
Keywords:
Status: CLOSED DUPLICATE of bug 1585393
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 29
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-17 07:29 UTC by Milan Zink
Modified: 2020-05-26 02:57 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-18 06:16:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Milan Zink 2018-10-17 07:29:41 UTC
Description of problem:

Copy & paste doesn't work with firefox-wayland outside application. Works only inside firefox between tabs, address bar.. No matter if Ctrl+C/V or middle button mouse.


Version-Release number of selected component (if applicable):
firefox-wayland-62.0.3-4.fc29.x86_64

How reproducible:
Run firefox-wayland, copy text some text, try to paste into other application (text editor, terminal..)

Steps to Reproduce:
1. run firefox-wayland
2. open some webpage, copy piece of text
3. try to paste it outside firefox to terminal or text editor

Actual results:
Clipboard doesn't work outside


Expected results:
Clipboard works normally

Additional info:

Comment 1 Martin Stransky 2018-10-17 09:19:44 UTC
Thanks, I've been hunting this one for a long time. It's perhaps https://bugzilla.mozilla.org/show_bug.cgi?id=1485916

How reliably you can reproduce that? Can you check if there's a copy or paste problem? You can check actual clipboard content by some clipboard manager like gpaste or clipit. Focus change may help or some delay after paste (https://gitlab.gnome.org/GNOME/gtk/issues/66)

Comment 2 Vít Ondruch 2018-10-17 14:43:00 UTC
The possible workaround for this issue is to use Drag&Drop.

Comment 3 Milan Zink 2018-10-17 16:50:51 UTC
Very, very weird. I've tried to reproduce it again and it was simply working. I'll try it once again after fresh boot. I'll send update tomorrow.

Comment 4 Martin Stransky 2018-10-18 06:16:58 UTC
Okay, thanks. We already track it as Bug 1585393 co closing as a dupe.

*** This bug has been marked as a duplicate of bug 1585393 ***


Note You need to log in before you can comment on or make changes to this bug.