Bug 1640054 - [admin] Long description of catalog item will be out of place and be overlapped by other item
Summary: [admin] Long description of catalog item will be out of place and be overlapp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Jeff Phillips
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-17 09:13 UTC by Yanping Zhang
Modified: 2019-06-04 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Settings for the tile component did not account for large amounts of text in the provider field Consequence: The long description was further down and not accurately faded out. Fix: Adjust the fadeout box based on the location of the long description text Result: Long description text is properly faded out indicating to the user that there is more info to be seen by clicking the tile
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
catalog-screenshot (129.64 KB, image/png)
2018-10-17 09:13 UTC, Yanping Zhang
no flags Details
screenshot-one (118.09 KB, image/png)
2018-11-02 03:18 UTC, Yanping Zhang
no flags Details
screenshot-two (73.75 KB, image/png)
2018-11-02 03:18 UTC, Yanping Zhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:56 UTC

Description Yanping Zhang 2018-10-17 09:13:20 UTC
Created attachment 1494770 [details]
catalog-screenshot

Description of problem:
On home catalog page, if the description of a catalog item is too long, the description will extend out of the frame and be overlapped by other item.

Version-Release number of selected component (if applicable):
registry.reg-aws.openshift.com:443/openshift/ose-console                       v4.0.0-0.20.0.0     f9dc1cabf379        4 days ago          252 MB


How reproducible:
Always

Steps to Reproduce:
1. On home catalog page, click "Middleware"->"Process Automation", check the result.
2.
3.

Actual results:
1. Those items with long description are overlapped.

Expected results:
1. Description should lay in frame correctly.

Additional info:

Comment 1 Jeff Phillips 2018-10-25 17:21:41 UTC
https://github.com/openshift/console/pull/669

Comment 2 Yanping Zhang 2018-10-26 02:59:11 UTC
registry.reg-aws.openshift.com:443/openshift/ose-console                    v4.0.0-0.32.0.0     d88722d7f46b        3 days ago          253 MB
Checked on ocp env with above console version, now the long description is truncated and won't extend out of frame. Most of long descriptions will end with "...", but some descriptions are truncated and doesn't end with "...", eg, "Dancer + Mysql (Ephemeral)". This doesn't look well.

@Jeff, Will you improve this issue?

Comment 3 Jeff Phillips 2018-10-26 20:03:24 UTC
@Yanping, I will fix this, I agree it does not look right.

Comment 4 Jeff Phillips 2018-11-01 13:16:50 UTC
@Yanping, Updated to show fading text for overflow. Sometimes the fade doesn't quite reach the last show word but making it longer is worse when the text does go to the end of the last visible line. Let me know what you think.

https://github.com/openshift/console/pull/718

Comment 5 Yanping Zhang 2018-11-02 03:16:43 UTC
brewregistry.stage.redhat.io/openshift/ose-console                   v4.0                48b464eda71c        About an hour ago   259 MB
Checked on ocp env with above console image version.
On catalog page, most of the catalog items with long descriptions end with fading text. I can see the special scenaio that the fading text is casually a "Space" behind a word, which looks like there is no fading text. It's not a big issue.
But for some catalog items, the last line of their descriptions is shown with upper half part. Refer to screenshot one.


I have an idea, if we can show catalog items as we do in old console, refer to screenshot two. Only show display name, no need to show description, user could check the description by clicking in the item.
eg:
openshift.io/display-name: JBoss EAP 6.4 + MySQL (Ephemeral with https)

It's up to dev to decide whether to improve the existing display or change the display context.

Comment 6 Yanping Zhang 2018-11-02 03:18:14 UTC
Created attachment 1500348 [details]
screenshot-one

Comment 7 Yanping Zhang 2018-11-02 03:18:44 UTC
Created attachment 1500349 [details]
screenshot-two

Comment 8 Jeff Phillips 2018-11-30 11:46:54 UTC
@Yanping I have a fix coming that will better fade the end of the description. UX has designed the page such that the user will not have to necessarily get details on each item by showing at least a portion of the description.

Comment 9 Jeff Phillips 2018-11-30 13:12:20 UTC
https://github.com/openshift/console/pull/884

Comment 10 Yanping Zhang 2018-12-12 06:10:58 UTC
atomic-openshift version: v4.0.0-0.94.0
registry.reg-aws.openshift.com:443/openshift/ose-console                   v4.0                656af44d0aff        4 hours ago         258 MB
Checked on ocp env with above console image, now the description of catalog items are shown well with fading text, and there is no overlap of the text.
The bug has been fixed, so move it to Verified.

Comment 13 errata-xmlrpc 2019-06-04 10:40:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.