Bug 1640061 - Purging ubuntu cluster using ansible is not removing ceph packages from nodes
Summary: Purging ubuntu cluster using ansible is not removing ceph packages from nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 3.2
Assignee: Rishabh Dave
QA Contact: sagrawal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-17 09:41 UTC by Ramakrishnan Periyasamy
Modified: 2019-01-03 19:02 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-ansible-3.2.0-0.1.rc2.el7cp Ubuntu: ceph-ansible_3.2.0~rc2-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible log (467.53 KB, text/plain)
2018-10-17 09:41 UTC, Ramakrishnan Periyasamy
no flags Details


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3286 None None None 2018-11-08 04:40:06 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:17 UTC

Description Ramakrishnan Periyasamy 2018-10-17 09:41:56 UTC
Created attachment 1494771 [details]
ansible log

Description of problem:

Purging ubuntu cluster using ansible is not removing ceph packages from ubuntu nodes.

ubuntu@magna066:/usr/share/ceph-ansible$ sudo dpkg -l | grep ceph
ii  ceph-ansible                        3.2.0~beta5-2redhat1                       all          Ansible playbooks for Ceph
rc  ceph-base                           12.2.8-14redhat1xenial                     amd64        common ceph daemon libraries and management tools
rc  ceph-common                         12.2.8-14redhat1xenial                     amd64        common utilities to mount and interact with a ceph storage cluster
rc  ceph-fuse                           12.2.8-14redhat1xenial                     amd64        FUSE-based client for the Ceph distributed file system
rc  ceph-mds                            12.2.8-14redhat1xenial                     amd64        metadata server for the ceph distributed file system
rc  ceph-mgr                            12.2.8-14redhat1xenial                     amd64        manager for the ceph distributed storage system
rc  ceph-mon                            12.2.8-14redhat1xenial                     amd64        monitor server for the ceph storage system


Version-Release number of selected component (if applicable):
ii  ansible                             2.6.5-2redhat1                             all          Ansible IT Automation
ii  ceph-ansible                        3.2.0~beta5-2redhat1                       all          Ansible playbooks for Ceph

How reproducible:
2/2

Steps to Reproduce:
1. Configure ubuntu cluster using ansible playbook
2. purge the cluster using playbook

Actual results:
NA

Expected results:
NA

Additional info:
NA

Comment 3 leseb 2018-10-17 13:13:29 UTC
Do we still support Ubuntu?

Comment 4 Ken Dreyer (Red Hat) 2018-10-23 23:04:29 UTC
Yes

Comment 11 errata-xmlrpc 2019-01-03 19:02:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.