Bug 164012 - updateDiskless does not always include all necessary kernel modules in initrd
updateDiskless does not always include all necessary kernel modules in initrd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On: 163951
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-07-22 17:00 EDT by Jason Vas Dias
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2005-484
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 09:48:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2005-07-22 17:00:19 EDT
+++ This bug was initially created as a clone of Bug #163951 +++

Description of problem:
updateDiskless copies all network driver modules from the client root into the
initrd, but fails to include dependency modules outside the /drivers/net subdir. 
For example the pcnet32 modules requires 'crc32.o', which is located in /lib and
thefore won't be copied into the initrd.
The result is that the diskless client will not boot because it cannot load the
kernel module for its network card. 

Version-Release number of selected component (if applicable):
redhat-config-netboot-0.1.18-1_EL3

How reproducible:
always

Steps to Reproduce:
1. setup a diskless client with a pcnet32 network card, following the
intructions in the Sytem Administrator Guide
2. boot the client.
3.
  
Actual results:
Kernel panic at boot, because the NFS root fs could not be mounted due to
failure to load the pcnet32 netwerk module.

Expected results:
The diskless system should have booted properly.

Additional info:
In this instance the problem can be solved easily by including
/lib/modules/`uname -r`/kernel/lib in the the initrd.
Comment 1 Jason Vas Dias 2005-07-22 18:41:11 EDT
This bug is now fixed with system-config-netboot-0.1.22-1_EL4 .
Comment 4 Red Hat Bugzilla 2005-10-05 09:48:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-484.html

Note You need to log in before you can comment on or make changes to this bug.