Bug 164040 - rpm rebuilddb Segmentation fault
rpm rebuilddb Segmentation fault
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-23 02:56 EDT by Robert Stuart
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 18:33:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
initial rpm list (11.21 KB, text/plain)
2005-07-23 03:02 EDT, Robert Stuart
no flags Details
rpm package list towards the end of my installation (11.40 KB, text/plain)
2005-07-23 03:04 EDT, Robert Stuart
no flags Details

  None (edit)
Description Robert Stuart 2005-07-23 02:56:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
I am getting segmentation faults when using rpm.  I can fix them temporarily, with some combinations of 
# /bin/rm /var/lib/rpm/__d*; /bin/rm /var/lib/rpm/Pubkeys
# rpm -qa > /tmp/r7
# rpm --rebuilddb -vv
# rpm -qa |wc

but the problem keeps coming back when trying to install another package with yum.


First noticed when trying to:
# yum localinstall java-1.5.0-sun-*
which died halfway through the initial downloading of indexes etc (I didn't have unixODBC installed at the time).


Version-Release number of selected component (if applicable):
rpm-4.4.1-22

How reproducible:
Sometimes

Steps to Reproduce:
see above.

# rpm -qa > /tmp/r8
Segmentation fault
# /bin/rm /var/lib/rpm/__d*; /bin/rm /var/lib/rpm/Pubkeys
# rpm -qa > /tmp/r8
# rpm --rebuilddb -vv
<snip lot of output>
D: adding "gok" to Name index.
D: adding 718 entries to Basenames index.
D: adding "Desktop/Accessibility" to Group index.
D: adding 56 entries to Requirename index.
D: adding "gok" to Providename index.
D: adding 116 entries to Dirnames index.
D: adding 56 entries to Requireversion index.
D: adding "1.0.3-1" to Provideversion index.
D: adding 1 entries to Installtid index.
D: adding 1 entries to Sigmd5 index.
D: adding "7acf85ae851014762bf0acd5423c414383c51a69" to Sha1header index.
Segmentation fault
# /bin/rm /var/lib/rpm/__d*; /bin/rm /var/lib/rpm/Pubkeys
# rpm -qa > /tmp/r8
# rpm --rebuilddb -vv
<snip output>
D: closed   db environment /var/lib/rpmrebuilddb.3959/Packages
D: removing directory /var/lib/rpmrebuilddb.3959
D: closed   db index       /var/lib/rpm/Pubkeys
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))


Actual Results:  results included above.  The db did rebuild on the second attempt

Expected Results:  I shouldn't have had to rebuild the db or get the segmentation fault

Additional info:

before I reproduced the problem, I installed numerous more packages and had to reinstall numerous keys (all of my repos).  This is frustrating that this happens over and over again.

# /bin/ls /etc/yum.repos.d/
atrpms.repo  fedora-devel.repo         fedora.repo                  freshrpms.repo dag.repo     fedora-extras-devel.repo  fedora-updates.repo          jpackage.repo dries.repo   fedora-extras.repo        fedora-updates-testing.repo  livna.repo

not all repos are enabled:
# grep enable /etc/yum.repos.d/*
/etc/yum.repos.d/atrpms.repo:enabled=0
/etc/yum.repos.d/dag.repo:enabled=1
/etc/yum.repos.d/fedora-devel.repo:enabled=0
/etc/yum.repos.d/fedora-extras-devel.repo:enabled=0
/etc/yum.repos.d/fedora-extras.repo:enabled=1
/etc/yum.repos.d/fedora.repo:enabled=1
/etc/yum.repos.d/fedora-updates.repo:enabled=1
/etc/yum.repos.d/fedora-updates-testing.repo:enabled=0
/etc/yum.repos.d/freshrpms.repo:enabled=1
/etc/yum.repos.d/jpackage.repo:enabled=0
/etc/yum.repos.d/jpackage.repo:enabled=0
/etc/yum.repos.d/livna.repo:enabled=0
/etc/yum.repos.d/livna.repo:enabled=0
Comment 1 Robert Stuart 2005-07-23 03:02:23 EDT
Created attachment 117096 [details]
initial rpm list

this is the rpm list before I started the installation of the java packages
Comment 2 Robert Stuart 2005-07-23 03:04:42 EDT
Created attachment 117097 [details]
rpm package list towards the end of my installation

This is a list of rpms near the end of my session of installs.	I use yum most
of the time, but used rpm to install the java rpms as they didn't have a
signature (they are jpackage rebuild nosrc rpms).
Comment 3 Robert Stuart 2005-07-23 03:09:01 EDT
another way to reproduce this problem is to simply do:
rpm -qa > /dev/null

over and over and eventually the segfault kicks in:

[root@paladin /]# rpm -qa > /tmp/r9
[root@paladin /]# rpm -qa > /tmp/r9
[root@paladin /]# rpm -qa > /tmp/r9
[root@paladin /]# rpm -qa > /tmp/r9
Segmentation fault

# uname -a
Linux paladin 2.6.12-1.1398_FC4 #1 Fri Jul 15 00:52:32 EDT 2005 i686 athlon i386
GNU/Linux
Comment 4 Jeff Johnson 2005-10-31 11:12:48 EST
I ran rpm -qa > /dev/null in a loop on i686 for over an hour w/o problem.

With rpm-4.4.3-0.28 if that matters (I know of no pertinent changes since 4.4.1,
but RH has RH peculier patches to rpm-4.4.1-22).

So IMHO, that means that there is something peculier to your machine.

What kernel?
What glibc?
Are you running NPTL?
Comment 5 Jeff Johnson 2006-02-13 18:33:38 EST
No response, closing ...

Note You need to log in before you can comment on or make changes to this bug.