Bug 1640429 - rdesktop connection error
Summary: rdesktop connection error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rdesktop
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jon Disnard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-18 03:45 UTC by Rob Thomas
Modified: 2019-02-13 06:14 UTC (History)
10 users (show)

Fixed In Version: rdesktop-1.8.4-2.fc29 rdesktop-1.8.4-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 06:14:29 UTC


Attachments (Terms of Use)

Description Rob Thomas 2018-10-18 03:45:56 UTC
Description of problem:
Long time rdesktop user. I have a bunch of xrdp machines set up as virtual machines. I use rdesktop tp connect. Connecting to the instance hasn't been a problem until about two weeks ago. I don't see a trouble ticket on it so I figured I should create one.

Version-Release number of selected component (if applicable):
Fedora 28, both sides. KDE/plasma Desktop for my desktop. Target machine is running xfce.

How reproducible:
Every time.

Steps to Reproduce:
1.rdesktop -g 2460x1340 192.168.2.13 &
2.
3.

Actual results:
[1] 14243
[robert@firefox ~]$ Autoselected keyboard map en-us
Connection established using SSL.
ERROR: SSL_write: 1 (Success)


Expected results:
Should fire up a login screen. Nothing appears.

Additional info:
I use this all the time. Really nice way to test a machine and if I make a mistake, I can recover it or re-load easily. The machine has been working fine and broken when I updated my desktop.

The last time I successfully logged in was 10/10 at 21:07. Being notified that there were updates, I updated. Here is a list of updates from that day:

bluedevil-5.13.5-1.fc28.x86_64                Wed 10 Oct 2018 10:00:12 PM EDT
kde-style-breeze-5.13.5-1.fc28.x86_64         Wed 10 Oct 2018 10:00:11 PM EDT
kdeplasma-addons-5.13.5-1.fc28.x86_64         Wed 10 Oct 2018 10:00:11 PM EDT
fedora-release-28-3.noarch                    Wed 10 Oct 2018 10:00:11 PM EDT
kinfocenter-5.13.5-1.fc28.x86_64              Wed 10 Oct 2018 10:00:09 PM EDT
plasma-desktop-doc-5.13.5-1.fc28.noarch       Wed 10 Oct 2018 10:00:08 PM EDT
pam-kwallet-5.13.5-1.fc28.x86_64              Wed 10 Oct 2018 10:00:08 PM EDT
ksshaskpass-5.13.5-1.fc28.x86_64              Wed 10 Oct 2018 10:00:08 PM EDT
sddm-kcm-5.13.5-1.fc28.x86_64                 Wed 10 Oct 2018 10:00:07 PM EDT
rust-srpm-macros-6-1.fc28.noarch              Wed 10 Oct 2018 10:00:07 PM EDT
plasma-user-manager-5.13.5-1.fc28.x86_64      Wed 10 Oct 2018 10:00:07 PM EDT
plasma-drkonqi-5.13.5-1.fc28.x86_64           Wed 10 Oct 2018 10:00:07 PM EDT
xerces-c-3.2.2-1.fc28.x86_64                  Wed 10 Oct 2018 10:00:06 PM EDT
plasma-nm-vpnc-5.13.5-1.fc28.x86_64           Wed 10 Oct 2018 10:00:06 PM EDT
plasma-nm-pptp-5.13.5-1.fc28.x86_64           Wed 10 Oct 2018 10:00:06 PM EDT
plasma-nm-openvpn-5.13.5-1.fc28.x86_64        Wed 10 Oct 2018 10:00:06 PM EDT
plasma-nm-openswan-5.13.5-1.fc28.x86_64       Wed 10 Oct 2018 10:00:06 PM EDT
plasma-nm-openconnect-5.13.5-1.fc28.x86_64    Wed 10 Oct 2018 10:00:06 PM EDT
plasma-nm-l2tp-5.13.5-1.fc28.x86_64           Wed 10 Oct 2018 10:00:06 PM EDT
qt5-style-oxygen-5.13.5-1.fc28.x86_64         Wed 10 Oct 2018 10:00:05 PM EDT
openblas-openmp-0.3.3-2.fc28.x86_64           Wed 10 Oct 2018 10:00:05 PM EDT
openblas-serial-0.3.3-2.fc28.x86_64           Wed 10 Oct 2018 10:00:04 PM EDT
openblas-threads-0.3.3-2.fc28.x86_64          Wed 10 Oct 2018 10:00:03 PM EDT
openblas-threads64_-0.3.3-2.fc28.x86_64       Wed 10 Oct 2018 10:00:02 PM EDT
kscreen-5.13.5-1.fc28.x86_64                  Wed 10 Oct 2018 10:00:02 PM EDT
sddm-breeze-5.13.5-1.fc28.noarch              Wed 10 Oct 2018 10:00:01 PM EDT
plasma-integration-5.13.5-1.fc28.x86_64       Wed 10 Oct 2018 10:00:01 PM EDT
plasma-discover-flatpak-5.13.5-1.fc28.x86_64  Wed 10 Oct 2018 10:00:01 PM EDT
ksysguard-5.13.5-1.fc28.x86_64                Wed 10 Oct 2018 10:00:01 PM EDT
kde-gtk-config-5.13.5-1.fc28.x86_64           Wed 10 Oct 2018 10:00:01 PM EDT
plasma-workspace-5.13.5-1.fc28.x86_64         Wed 10 Oct 2018 10:00:00 PM EDT
plasma-desktop-5.13.5-1.fc28.x86_64           Wed 10 Oct 2018 09:59:56 PM EDT
plasma-lookandfeel-fedora-5.13.5-1.fc28.noarch Wed 10 Oct 2018 09:59:52 PM EDT
kactivitymanagerd-5.13.5-1.fc28.x86_64        Wed 10 Oct 2018 09:59:52 PM EDT
breeze-cursor-theme-5.13.5-1.fc28.noarch      Wed 10 Oct 2018 09:59:52 PM EDT
plasma-systemsettings-5.13.5-1.fc28.x86_64    Wed 10 Oct 2018 09:59:51 PM EDT
kdesu-5.13.5-1.fc28.x86_64                    Wed 10 Oct 2018 09:59:51 PM EDT
kde-cli-tools-5.13.5-1.fc28.x86_64            Wed 10 Oct 2018 09:59:51 PM EDT
plasma-workspace-libs-5.13.5-1.fc28.x86_64    Wed 10 Oct 2018 09:59:50 PM EDT
libksysguard-5.13.5-1.fc28.x86_64             Wed 10 Oct 2018 09:59:50 PM EDT
kwrited-5.13.5-1.fc28.x86_64                  Wed 10 Oct 2018 09:59:50 PM EDT
kmenuedit-5.13.5-1.fc28.x86_64                Wed 10 Oct 2018 09:59:50 PM EDT
plasma-breeze-common-5.13.5-1.fc28.noarch     Wed 10 Oct 2018 09:59:49 PM EDT
plasma-breeze-5.13.5-1.fc28.x86_64            Wed 10 Oct 2018 09:59:49 PM EDT
oxygen-sound-theme-5.13.5-1.fc28.noarch       Wed 10 Oct 2018 09:59:49 PM EDT
libksysguard-common-5.13.5-1.fc28.x86_64      Wed 10 Oct 2018 09:59:49 PM EDT
xdg-desktop-portal-kde-5.13.5-1.fc28.x86_64   Wed 10 Oct 2018 09:59:48 PM EDT
polkit-kde-5.13.5-1.fc28.x86_64               Wed 10 Oct 2018 09:59:48 PM EDT
plasma-workspace-geolocation-libs-5.13.5-1.fc28.x86_64 Wed 10 Oct 2018 09:59:48 PM EDT
plasma-workspace-geolocation-5.13.5-1.fc28.x86_64 Wed 10 Oct 2018 09:59:48 PM EDT
plasma-pa-5.13.5-1.fc28.x86_64                Wed 10 Oct 2018 09:59:48 PM EDT
plasma-milou-5.13.5-1.fc28.x86_64             Wed 10 Oct 2018 09:59:48 PM EDT
khotkeys-5.13.5-1.fc28.x86_64                 Wed 10 Oct 2018 09:59:48 PM EDT
kwin-common-5.13.5-1.fc28.x86_64              Wed 10 Oct 2018 09:59:47 PM EDT
kwin-5.13.5-1.fc28.x86_64                     Wed 10 Oct 2018 09:59:47 PM EDT
powerdevil-5.13.5-1.fc28.x86_64               Wed 10 Oct 2018 09:59:46 PM EDT
plasma-discover-5.13.5-1.fc28.x86_64          Wed 10 Oct 2018 09:59:46 PM EDT
perl-Git-2.17.2-1.fc28.noarch                 Wed 10 Oct 2018 09:59:45 PM EDT
git-core-doc-2.17.2-1.fc28.noarch             Wed 10 Oct 2018 09:59:45 PM EDT
git-2.17.2-1.fc28.x86_64                      Wed 10 Oct 2018 09:59:45 PM EDT
plasma-browser-integration-5.13.5-1.fc28.x86_64 Wed 10 Oct 2018 09:59:44 PM EDT
git-core-2.17.2-1.fc28.x86_64                 Wed 10 Oct 2018 09:59:44 PM EDT
plasma-discover-libs-5.13.5-1.fc28.x86_64     Wed 10 Oct 2018 09:59:43 PM EDT
libkscreen-qt5-5.13.5-1.fc28.x86_64           Wed 10 Oct 2018 09:59:43 PM EDT
kwin-libs-5.13.5-1.fc28.x86_64                Wed 10 Oct 2018 09:59:43 PM EDT
ksysguardd-5.13.5-1.fc28.x86_64               Wed 10 Oct 2018 09:59:43 PM EDT
plasma-workspace-common-5.13.5-1.fc28.x86_64  Wed 10 Oct 2018 09:59:42 PM EDT
libkworkspace5-5.13.5-1.fc28.x86_64           Wed 10 Oct 2018 09:59:42 PM EDT
kscreenlocker-5.13.5-1.fc28.x86_64            Wed 10 Oct 2018 09:59:42 PM EDT
plasma-nm-5.13.5-1.fc28.x86_64                Wed 10 Oct 2018 09:59:41 PM EDT
openblas-0.3.3-2.fc28.x86_64                  Wed 10 Oct 2018 09:59:41 PM EDT
kdecoration-5.13.5-1.fc28.x86_64              Wed 10 Oct 2018 09:59:41 PM EDT

I strongly suspect something in this list broke it.

Please let me know if I can help. Special key-in, tcpdump, etc.

Comment 1 Rob Thomas 2018-10-29 03:20:51 UTC
I fired up a Windows 2012 R2 machine. rdesktop worked fine. I loaded a brand new F28 xfe server and loaded stock xrdp. No other updates, just xrdp. Same problem.

Comment 2 Byron Peters 2018-11-05 16:10:37 UTC
I am having exactly the same problem. FWIW, the problem continues on Fedora 29. Have tried rdesktop from multiple F28/F29 clients to multiple xrdp F28 hosts.

Comment 3 Gabriel Somlo 2018-12-11 16:24:57 UTC
I have source and x86_64 RPMs for the latest git upstream (with an added software-mouse-jiggler out-of-tree patch) here:

http://www.contrib.andrew.cmu.edu/~somlo/RDP/rdesktop-1.8.3-3.post.20181211git1f13bf5.fc28.src.rpm

and

mirror.ini.cmu.edu/gls/28/x86_64/rdesktop-1.8.3-3.post.20181211git1f13bf5.fc28.x86_64.rpm

I'd be curious if this fixes the problem ?

Comment 4 Rob Thomas 2018-12-12 01:04:34 UTC
Hi. Thanks for the effort. I had to install  libao-devel libsamplerate-devel pcsc-lite-devel, which is fine. Compiled without a problem and created the RPM. Installed it.

So now it's asking me for a password on the command line instead of in the remote window. Wrong password, correct password, it just sits there until I hit control-c. Even for a real windows 2012 box.

Thanks,
Rob

[robert@firefox ~]$ rdesktop -g 2460x1340 192.168.2.13 &
[1] 7243
[robert@firefox ~]$ Autoselecting keyboard map 'en-us' from locale
Password: 

[1]+  Stopped                 rdesktop -g 2460x1340 192.168.2.13
[robert@firefox ~]$ fg
rdesktop -g 2460x1340 192.168.2.13



[robert@firefox ~]$

Comment 5 Gabriel Somlo 2018-12-12 02:32:23 UTC
Does that for me as well. I use it like this:

  rdesktop -d MYDOMAIN -u myusername -p ' ' -f server.ip.address

Haven't spent any cycles figuring out how to get it to *not* ask for a password on the terminal. Giving it the wrong one via cmdline gets me to where I have a chance to enter it again into a real windows login prompt. There's probably a proper way to do this, but I've been procrastinating ever since I found this silly workaround...

Comment 6 Rob Thomas 2018-12-12 03:38:10 UTC
Closer. At least it popped up an X window. Then blew it away.

[robert@firefox ~]$ Autoselecting keyboard map 'en-us' from locale
Protocol(error): tcp_tls_connect(), 0x1409442e:SSL routines:ssl3_read_bytes: tlsv1 alert protocol version
Connection established using plain RDP.
Clipboard(error): xclip_handle_SelectionNotify(), unable to find a textual target to satisfy RDP clipboard text request
Clipboard(error): xclip_handle_SelectionNotify(), unable to find a textual target to satisfy RDP clipboard text request
Sound(warning): rdpsnd_process_packet(), Unhandled opcode 0x27
disconnect: Unknown reason.

Comment 7 Rob Thomas 2018-12-12 04:34:19 UTC
Problem was between the keyboard and the chair. I had a session open from a Windows server. I really thought that VM host had been rebooted. It doesn't like it when I remote shell in again. So I terminated the windows session, tried again and poof. Comes right up. Comes right up with the Windows machine as well. The only change to the command line was the -p option. No password option, it won't work.

Comment 8 Gabriel Somlo 2018-12-12 12:54:08 UTC
so I believe the "must have -p" thing is an upstream regression of some sort, but I haven't yet worked up the courage to go and bisect it -- too scared of having to jump around the openssl 1.0 -> 1.1 switch while I'm at it :)

Comment 9 Gabriel Somlo 2018-12-12 21:55:49 UTC
(In reply to Gabriel Somlo from comment #8)
> too scared of having to jump around the openssl 1.0 -> 1.1 switch while I'm at it :)

Turns out I don't have to bisect, there's already a pull request to revert the "-p manadatory" thing:
https://github.com/rdesktop/rdesktop/pull/216

And an argument between users and maintainers on the same topic here:
https://github.com/rdesktop/rdesktop/issues/262

After some more experimentation, if I hit enter at the password prompt I get a failed login and the chance to enter it again via the destination machine's graphical password mechanism. Same thing happens if I use a space as the password ( "-p ' '"), my current workaround.

Personally I think forcibly assuming "-p -" even in the absence of a -p command line flag is hostile to the user, but then again, that's not a surprise based on my past experience with rdesktop (see https://github.com/rdesktop/rdesktop/pull/23) :(

Comment 10 Rob Thomas 2018-12-13 04:08:35 UTC
User hostile, sure.

Curious about the remote connection failing to work all of a sudden. Seems they would test before committing.

Comment 11 Fedora Update System 2019-01-29 15:46:30 UTC
rdesktop-1.8.4-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5146cd34e2

Comment 12 Fedora Update System 2019-01-29 15:46:46 UTC
rdesktop-1.8.4-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ac70292cfc

Comment 13 Fedora Update System 2019-01-30 01:58:54 UTC
rdesktop-1.8.4-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ac70292cfc

Comment 14 Fedora Update System 2019-01-30 03:01:32 UTC
rdesktop-1.8.4-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5146cd34e2

Comment 15 Fedora Update System 2019-02-13 02:46:44 UTC
rdesktop-1.8.4-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Rob Thomas 2019-02-13 03:08:58 UTC
The problem is still occurring. Even in a brand new install that has been updated. Brand new VM, brand new Desktop load.

Comment 17 Fedora Update System 2019-02-13 06:14:29 UTC
rdesktop-1.8.4-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.