Bug 164051 - "Unhandled event" in hidups driver
"Unhandled event" in hidups driver
Status: CLOSED DUPLICATE of bug 160700
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-07-23 07:44 EDT by Matthew Saltzman
Modified: 2015-01-04 17:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-05 01:29:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2005-07-23 07:44:03 EDT
Description of problem:

When unning nut with the hidups driver, I get entries in /var/log/messages every
5 seconds, as follows:

Jul 17 04:02:52 yankee hidups[2046]: Ignoring x86 page event 0xff860060 (8)
Jul 17 04:02:56 yankee last message repeated 2 times
Jul 17 04:02:56 yankee hidups[2046]: Unhandled event: 0x8500d1 (1)
Jul 17 04:02:56 yankee hidups[2046]: Unhandled event: 0x850043 (0)
Jul 17 04:02:56 yankee hidups[2046]: Unhandled event: 0x85004b (0)
Jul 17 04:02:56 yankee hidups[2046]: Unhandled event: 0x840065 (0)
Jul 17 04:02:56 yankee hidups[2046]: Ignoring x86 page event 0xff860060 (8)
Jul 17 04:03:01 yankee last message repeated 3 times

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Configure nut for UPS that uses hidups.
2. Start the ups service.
3. Watch /var/log/messages.
Actual results:
The log entries above appear every 5 seconds.

Expected results:
The occasional status message.

Additional info:
Tested on three different machines with three different APC UPS's using the same
USB driver.  This is a regression from FC3, where everything worked fine.
Comment 1 Ngo Than 2005-08-25 13:03:11 EDT
It seems a problem in usb driver. There's no difference in hidups between 
2.0.0 and 2.0.1! 
do you still see the warnings if you start nut-2.0.1-1 on FC3 system? 
Comment 2 Matthew Saltzman 2005-08-25 14:36:32 EDT
I don't have an FC3 system to test anymore, but I did not see this problem when
I was running FC3 with whatever nut version was included.
Comment 3 Matthew Saltzman 2005-09-24 08:25:49 EDT
Just noticed, this looks like a dup of #160700.
Comment 4 Dave Jones 2005-09-30 02:29:42 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel ( As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Comment 5 Matthew Saltzman 2005-09-30 09:27:06 EDT
This bug is not--repeat, not--fixed in kernel-2.6.13-1.1526_FC4.
Comment 6 Dave Jones 2005-11-05 01:29:22 EST

*** This bug has been marked as a duplicate of 160700 ***

Note You need to log in before you can comment on or make changes to this bug.