Bug 164066 - Looking for plugins in wrong place
Looking for plugins in wrong place
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gkrellm (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-23 17:37 EDT by Adam Goode
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: gkrellm-2.2.7-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 07:45:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Goode 2005-07-23 17:37:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Looks like the x86-64 version of gkrellm is looking in /usr/lib/gkrellm2/plugins for its plugins, not /usr/lib64/gkrellm2/plugins. Thus, no plugins are found, even though I have a few installed. (Plugins in the packages are going into /usr/lib64/gkrellm2/plugins.) Manual installation of plugins in $HOME/.gkrellm2/plugins works.


strace output of plugin searching:

stat("/home/adam/.gkrellm2/plugins", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/home/adam/.gkrellm2/plugin_enable", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/home/adam/.gkrellm2/plugin_placement", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/home/adam/.gkrellm2/plugins", O_RDONLY|O_NONBLOCK|O_DIRECTORY) = 7
open("/usr/local/lib/gkrellm2/plugins", O_RDONLY|O_NONBLOCK|O_DIRECTORY) = -1 ENOENT (No such file or directory)
open("/usr/lib/gkrellm2/plugins", O_RDONLY|O_NONBLOCK|O_DIRECTORY) = -1 ENOENT (No such file or directory)


Version-Release number of selected component (if applicable):
gkrellm-2.2.4-4

How reproducible:
Always

Steps to Reproduce:
gkrellm

Actual Results:  No plugins.

Expected Results:  Plugins should be selectable in the setup.

Additional info:
Comment 1 Karsten Hopp 2005-09-06 07:45:23 EDT
fixed in rawhide 

Note You need to log in before you can comment on or make changes to this bug.