Bug 164069 - Coda filesystem as kernel module per default
Coda filesystem as kernel module per default
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-23 18:18 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-30 02:43:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-07-23 18:18:58 EDT
Description of problem:
Is there a special reason, that the coda filesystem isn't built per default as 
kernel module ("# CONFIG_CODA_FS is not set")?! If the answer is "no", could it 
be build as module for futher kernel rebuilds, please?

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1435_FC5

Actual results:
No coda filesystem module.

Expected results:
Coda filesystem module.
Comment 1 Dave Jones 2005-07-30 02:43:10 EDT
basically insufficient demand.  Yours is the first request for this that I've
ever seen.

Additionally, lack of upstream activity means that any problems that would
surface would go unfixed.  (the coda project seems to be doing something, but
the in-kernel implementation hasn't seen a lot of attention in a long time)
ISTR the upstream developers went on to work on intermezzo, and then gave up on
that too, and ended up working on lustre ?

Note You need to log in before you can comment on or make changes to this bug.