Bug 164071 - metacity crashes with windows that have titles longer than 65535 pixels
metacity crashes with windows that have titles longer than 65535 pixels
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-07-23 19:21 EDT by Bill Crawford
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-01 17:00:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2005-07-23 19:21:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050723 Fedora/1.1-0.2.4.deerpark.alpha2 Firefox/1.0+

Description of problem:
Metacity goes into a loop, restarting over and over again.  This was apparently triggered by opening a firefox window with a very, very long title.

Version-Release number of selected component (if applicable):
2.11.0-3

How reproducible:
Didn't try

Steps to Reproduce:
1. Open a firefox window with a very, very long title.

  

Actual Results:  Every time I switched to the desktop with the firefox window, metacity restarted (well, crashed, and gnome-session restarted it).

Expected Results:  It should have not crashed.  Perhaps truncate the title?

Additional info:

Bug in window manager: Unexpected X error: BadLength (poly request too large or 
internal Xlib length erro serial 260605 error_code 16 request_code 14 minor_code
 0)
Window manager warning: Lost connection to the display ':0.0';
most likely the X server was shut down or you killed/destroyed
the window manager.
Window manager warning: Lost connection to the display ':0.0';
most likely the X server was shut down or you killed/destroyed
the window manager.
Window manager warning: Lost connection to the display ':0.0';
most likely the X server was shut down or you killed/destroyed
the window manager.
Window manager warning: Lost connection to the display ':0.0';
most likely the X server was shut down or you killed/destroyed
the window manager.
Window manager warning: Lost connection to the display ':0.0';
most likely the X server was shut down or you killed/destroyed
the window manager.
Bug in window manager: Unexpected X error: BadLength (poly request too large or 
internal Xlib length erro serial 18440 error_code 16 request_code 17 minor_code 
0)


... etc

I'm marking this "high" because, well, it's the window manager. Without it, it's hard to do anything ..
Comment 1 Ray Strode [halfline] 2005-09-01 17:00:23 EDT
Hi,

This should be fixed in tomorrow's rawhide.

Note You need to log in before you can comment on or make changes to this bug.