Bug 1640794 - dmeventd_vdo.c has code path that can dereference NULL
Summary: dmeventd_vdo.c has code path that can dereference NULL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kmod-kvdo
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Joe Shimkus
QA Contact: Jakub Krysl
URL:
Whiteboard:
Depends On:
Blocks: 1640795
TreeView+ depends on / blocked
 
Reported: 2018-10-18 18:53 UTC by Joe Shimkus
Modified: 2019-08-06 13:08 UTC (History)
4 users (show)

Fixed In Version: 6.1.2.19
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1640795 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:08:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2233 None None None 2019-08-06 13:08:25 UTC

Description Joe Shimkus 2018-10-18 18:53:11 UTC
Description of problem:
In register_device() if the pool allocation fails the state variable will remain NULL and the code will attempt to deference it.

Comment 3 Jakub Krysl 2019-05-31 13:35:54 UTC
Regression testing could not find any issues.
kernel-3.10.0-1048.el7.x86_64
vdo-6.1.2.41-4.el7.x86_64
kmod-kvdo-6.1.2.41-5.el7.x86_64

Comment 5 errata-xmlrpc 2019-08-06 13:08:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2233


Note You need to log in before you can comment on or make changes to this bug.