Bug 164092 - [sunjava] OOo-1.9.xxx and java interaction
[sunjava] OOo-1.9.xxx and java interaction
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-24 14:06 EDT by Sammy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-27 11:07:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2005-07-24 14:06:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.2 (like Gecko)

Description of problem:
When I try to run openoffice macros (like Word cnt) I get an error saying that 
/usr/...../libjawt.so: libmlib_image.so not found. Where the path is the location 
of my SUN jdk installation and libmlib_image.so is in that directory. 
 
My question is: Are these supposed to work? With sun's jdk (1.5.0_03)? or 
are they converted to gcj? 
 
I do not have the java compatibilty rpm's installed. If this is the problem we may 
need a Requirement. 
 
Thanks 

Version-Release number of selected component (if applicable):
OOo-1.9.120

How reproducible:
Always

Steps to Reproduce:
1. start any oo application 
2. Try to run Tools-->Macros-->run--->oo macros-->wordcnt 
3. 
   

Additional info:
Comment 1 Caolan McNamara 2005-07-25 03:37:39 EDT
hmm, you got sun jdk installed. in tools->options->java which jdk is selected ?,
the sun jdk one I presume. It's set first in the search for jdks

That error looks like it cannot find libmlib_image.so, I suspect that's because
the soffice.sh is tweaked to remove LD_LIBRARY_PATH stuff which is unnecessary
for  the stock rawhide OOo, but may be partially required to get this sort of
config working. 

I'll reintroduce the LD_LIBRARY_PATH if javaldx returns something for 1.9.121
which may resolve this for using the sun jdk with FC OOo
Comment 2 Caolan McNamara 2005-07-25 03:44:05 EDT
hang on, I already did that. 

Can you take a look at the /usr/lib/openoffice.org2.0/program/soffice script,
and see if there is any output from running
/usr/lib/openoffice.org2.0/program/javaldx
Comment 3 Sammy 2005-07-25 09:40:11 EDT
Yes,

# /usr/lib/openoffice.org2.0/program/javaldx
/usr/java/jre/lib/i386/client:/usr/java/jre/lib/i386/native_threads:/usr/java/jre/lib/i386

which are all the correct locations where java is installed.
Comment 4 Caolan McNamara 2005-07-25 09:50:53 EDT
and just before 
# execute soffice binary
"$sd_prog/$sd_binary" "$@"
in the soffice script add echo $LD_LIBRARY_PATH just to verify that it's set at
this stage correctly
Comment 5 Sammy 2005-07-25 10:27:58 EDT
It gives this:

/usr/java/jre/lib/i386/client:/usr/java/jre/lib/i386/native_threads:/usr/java/jre/lib/i386

same as above.
Comment 6 Caolan McNamara 2005-07-25 10:37:04 EDT
then basically it should work assuming that libmlib_image.so is in one of those
directories :-(
Comment 7 Sammy 2005-07-25 11:54:48 EDT
Well, it is in the /usr/java/jre/lib/i386 directory. However, some libs are
either under client/server directories.

So, I went and configured ld.so.conf by adding the two directories and doing
an ldconfig. Yhis did not work for some, even though the /usr/java/jre/lib/i386
was in the path some libs were not found. I had to make logical links from the
client subdirectory to one up, and finally got everything to find each other.

I installed jdk rpm from sun and I am surprised this was not organized better.
May be the order of paths is important.

Anyhow, now when I try to execute, say wordcount, I do not get the not found
message. Instead I get an error message:

Beanshell indicateErrorLine 34

and one of the macros crashed:

=========================================================================

Beanshell indicateErrorLine 13

#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  SIGSEGV (0xb) at pc=0xb319c8f7, pid=27926, tid=3086141104
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_04-b05 mixed mode, sharing)
# Problematic frame:
# C  [libsvx680li.so+0x3208f7]
#
# An error report file with more information is saved as hs_err_pid27926.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#

---start copy and paste here---
0xab3b96: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db96
0xab43e4: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3e4
0x51d420:  + 0x420 (__kernel_sigreturn + 0x0)
0x6a5cf28: /lib/libc.so.6 + 0x29f28 (abort + 0xf8)
0xb18239e5: /usr/java/jre/lib/i386/client/libjvm.so + 0x25b9e5
0xb18ac994: /usr/java/jre/lib/i386/client/libjvm.so + 0x2e4994
0xb1828134: /usr/java/jre/lib/i386/client/libjvm.so + 0x260134
(JVM_handle_linux_signal + 0x244)
0xb1825664: /usr/java/jre/lib/i386/client/libjvm.so + 0x25d664
0x51d440:  + 0x440 (__kernel_rt_sigreturn + 0x0)
0x9f0b75: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x253b75
(SvTreeListBox::Expand(SvLBoxEntry*) + 0x2d)
0xb319bade: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x31fade
0x9e654a: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x24954a
0x9eb05a: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x24e05a
0x9eebde: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x251bde
(SvTreeListBox::MouseButtonDown(MouseEvent const&) + 0x20)
0x2ded3b: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cdd3b
0x2e03ed: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cf3ed
0x2df1ec: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1ce1ec
0x6c217a2: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1a7a2
0x6c21330: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1a330
0x226b502: /usr/lib/libgtk-x11-2.0.so.0 + 0x130502
0x14be7ab: /usr/lib/libgobject-2.0.so.0 + 0x87ab (g_closure_invoke + 0x153)
0x14ce29e: /usr/lib/libgobject-2.0.so.0 + 0x1829e
0x14cf935: /usr/lib/libgobject-2.0.so.0 + 0x19935 (g_signal_emit_valist + 0x448)
0x14cff29: /usr/lib/libgobject-2.0.so.0 + 0x19f29 (g_signal_emit + 0x29)
0x23615b9: /usr/lib/libgtk-x11-2.0.so.0 + 0x2265b9
0x226868c: /usr/lib/libgtk-x11-2.0.so.0 + 0x12d68c (gtk_propagate_event + 0xea)
0x2268c66: /usr/lib/libgtk-x11-2.0.so.0 + 0x12dc66 (gtk_main_do_event + 0x417)
0x71031b5: /usr/lib/libgdk-x11-2.0.so.0 + 0x421b5
0x10d2b8e: /usr/lib/libglib-2.0.so.0 + 0x24b8e (g_main_context_dispatch + 0x1dc)
0x10d5b96: /usr/lib/libglib-2.0.so.0 + 0x27b96
0x10d6078: /usr/lib/libglib-2.0.so.0 + 0x28078 (g_main_context_iteration + 0x66)
0x6c115d5: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa5d5
0x17e7dc5: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45dc5
(X11SalInstance::Yield(unsigned char) + 0x29)
0x191724: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x80724
(Application::Yield() + 0x50)
0x2868b8: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1758b8
(Dialog::Execute() + 0x166)
0x94dbfb0: /usr/lib/openoffice.org2.0/program/libcui680li.so + 0x53fb0
0x2736d32: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xa7d32
0x272edf8: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x9fdf8
0x2825c50: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x196c50
0x282503d: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19603d
0x282552e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19652e
(SfxDispatcher::_Execute(SfxShell&, SfxSlot const&, SfxRequest&, unsigned short)
+ 0x138)
0x282e73b: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19f73b
0x281cfdc: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x18dfdc
0x281d3fd: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x18e3fd
0x7622ced: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xa8ced
0x7622d78: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xa8d78
0x18b3aa: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7a3aa
0x29ac0a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x189c0a
(Menu::Select() + 0x3c)
0x295615: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x184615
0x295628: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x184628
0x18b3aa: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7a3aa
0x2df943: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1ce943
0x17c0e6a: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1ee6a
0x17e60fb: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x440fb
(SalDisplay::DispatchInternalEvent() + 0xad)
0x6c119af: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa9af
0x10d4df0: /usr/lib/libglib-2.0.so.0 + 0x26df0
0x10d2b8e: /usr/lib/libglib-2.0.so.0 + 0x24b8e (g_main_context_dispatch + 0x1dc)
0x10d5b96: /usr/lib/libglib-2.0.so.0 + 0x27b96
0x10d6078: /usr/lib/libglib-2.0.so.0 + 0x28078 (g_main_context_iteration + 0x66)
0x6c115d5: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa5d5
0x17e7dc5: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45dc5
(X11SalInstance::Yield(unsigned char) + 0x29)
0x191724: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x80724
(Application::Yield() + 0x50)
0x191762: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x80762
(Application::Execute() + 0x26)
0x8065670: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1d670
(desktop::Desktop::Main() + 0x149a)
0x196b51: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x85b51 (SVMain()
+ 0x45)
0x8060723: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18723 (sal_main +
0x47)
0x6a4841f: /lib/libc.so.6 + 0x1541f (__libc_start_main + 0xdf)
0x8060659: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18659
(Window::RequestHelp(HelpEvent const&) + 0x31)
---end copy and paste here---
paste the above into your bug report

Comment 8 Sammy 2005-07-25 15:15:53 EDT
Finally it is working. I put all the paths into ld.so.conf and had to make some logical links 
from i386/client directory to i386 directory (don't know why since these were libraries 
in the paths defined in ld.so.conf and ldconfig'ed). 
 
Should there be an "export LD_LIBRARY_PATH" in soffice? 
Comment 9 Caolan McNamara 2005-07-27 11:07:28 EDT
Well I don't know much about running sun java under Fedora, except for what the
release notes suggest i.e. that Fedora Core 4 users should use the RPM from
jpackage.org. Probably of little use to you. 

That soffice glue is the same as used in the normal upstream soffice. And the
javaldx output matches the output I get on a non fedora box compromised with
sunjava. I suggest taking this issue up with the upstream Sun built OOo where
they support sunjava, unless there it doesn't happen with their installsets.

Note You need to log in before you can comment on or make changes to this bug.