Bug 164107 - Describe problem, fix, or request for release notes
Describe problem, fix, or request for release notes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
http://fedoraproject.org/wiki/DocsPro...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-24 20:53 EDT by Chris Cantwell
Modified: 2014-08-31 19:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 07:03:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Cantwell 2005-07-24 20:53:14 EDT
I successfully installed FC4 on a PII-333smp machine (Intel mboard), using two 
mirrored RAID1 18GB SCSI drives aic7xxx.  I also have two Promise Ultra 100 TX2 
controllers, with 4 160GB PATA hard drives connected as master to each of four 
IDE channels, partitioned as RAID autodetect and recognized as hde, hdg, hdi, 
hdk.  I created a RAID5 array md4 with these 4 drives using mdadm, was able to 
format it (jfs filesystem in this case) and mount it (I created a mount point 
called /data, and modified fstab appropriately).  I was able to copy data to 
it, unmount and remount the volume, and inspection of /proc/mdstat showed the 
array to be normal.  When I rebooted the machine the array disappeared, no 
trace of md4, and using mdadm --scan resulting in an error message saying the 
array did not exist.  I have now discovered that the partion tables for all 
four drives have been erased.  This is repeatable, I did it twice.  The RAID1 
array on aic7xxx is unaffected, but the system crashed the first reboot while 
it tried to mount a non-existant RAID array (this is another serious bug!  the 
system should gracefully recover if it can't mount an external filesystem!). 
The second time I refrained from modifying fstab until I verified the problem.  
I followed the mdadm guidance explicitly, and cannot make this work, there are 
no existing bug reports on this subject.  I can do this task in Windows 
2000/XP/2003 within five minutes, why is it so difficult to create a RAID5 
array in Linux?  Chris Cantwell
Comment 1 Jay Fenlason 2005-07-25 09:52:53 EDT
I don't see any reference to Amanda in this bug.  What amanda configuration 
are you using, and what does your /etc/amanda/{config}/amanda.conf contain?  
Also, what backup medium are you using?  Tape?  Disk?  CD? 
Comment 2 Chris Cantwell 2005-08-26 07:02:53 EDT
This turned out not to be a bug in Amanda, I incorrectly used the mdadm 
command.  I tried to configure the RAID5 using the device naem /dev/hde etc. 
instead of the partition names /dev/hde1 etc.  Worked perfectly after I 
configured the RAID correctly.  Closed.

Note You need to log in before you can comment on or make changes to this bug.