Bug 1641268 - dracut-network: iscsi module causes device timeout on boots with resume= cmdline arg
Summary: dracut-network: iscsi module causes device timeout on boots with resume= cmdl...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
(Show other bugs)
Version: 29
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Keywords:
Depends On:
Blocks: F29FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-10-20 18:34 UTC by Dusty Mabe
Modified: 2018-10-30 17:31 UTC (History)
5 users (show)

Fixed In Version: dracut-049-11.git20181024.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-30 17:31:32 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dusty Mabe 2018-10-20 18:34:18 UTC
Description of problem:

Upstream bug: https://github.com/dracutdevs/dracut/issues/480


There is an odd interaction at play where having a `resume=` kernel command line arg as well as an initramfs that was built using `--no-hostonly --add iscsi` causes there to be a device timeout of the lvm swap device. This is occurring in Fedora 29 Atomic Host. A Fedora 29 Server system can show the problem easily by making sure `dracut-network` and `iscsi-initiator-utils` are installed and regenerating the initramfs with dracut -f --no-hostonly`. 

I have determined that this behavior [started happening with the `048` release of dracut](https://pagure.io/atomic-wg/issue/513#comment-537020). There were only three commits since `047` on the iscsi module-setup.sh so maybe it is one of them: b31f3fe 9e82732 5e615f4

The symptom you will see is a system that takes 90 seconds longer to boot and error messages something like:

```
Oct 17 23:05:41 localhost systemd[1]: dev-mapper-fedora\x2dswap.device: Job dev-mapper-fedora\x2dswap.device/start timed out.
Oct 17 23:05:41 localhost systemd[1]: Timed out waiting for device dev-mapper-fedora\x2dswap.device.
Oct 17 23:05:41 localhost systemd[1]: Dependency failed for Resume from hibernation using device /dev/mapper/fedora-swap.
```

There is a lot of detailed investigation over in https://pagure.io/atomic-wg/issue/513

`dracut-network-048-14.git20180726.fc29.x86_64`

Comment 1 Fedora Blocker Bugs Application 2018-10-20 18:40:15 UTC
Proposed as a Freeze Exception for 29-final by Fedora user dustymabe using the blocker tracking app because:

 This late in the game I doubt this will make it into final but I'd like to at least get it added to known bugs.

Comment 2 František Zatloukal 2018-10-22 16:45:13 UTC
Discussed during the 2018-10-22 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made:

"This bug has been noted to be a "nice-to-have" fix, so we accept it as an AcceptedFreezeException."

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-10-22/f29-blocker-review.2018-10-22-16.00.log.txt

Comment 3 Fedora Update System 2018-10-25 07:22:47 UTC
dracut-049-11.git20181024.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf5015ab11

Comment 4 Fedora Update System 2018-10-25 15:37:59 UTC
dracut-049-11.git20181024.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cf5015ab11

Comment 5 Fedora Update System 2018-10-30 17:31:32 UTC
dracut-049-11.git20181024.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.