Bug 164139 - anaconda/kernel mishandles partitioning of thinkpad harddrives with host protected area
anaconda/kernel mishandles partitioning of thinkpad harddrives with host prot...
Status: CLOSED DUPLICATE of bug 163419
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 07:07 EDT by Pekka Pietikäinen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 17:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2005-07-25 07:07:27 EDT
Description of problem:

Was asked to move bug from #163419 to here and under anaconda. I still blame the
kernel ;)

"There's a nasty FC3 <-> FC4 regression too related to host protected areas.

IBM thinkpads have a few GB recovery area in the host protected area that FC3
happily ignored. FC4 overrides the BIOS/harddisk and thinks it can use the
entire disk. Which means anaconda makes partitions that fill the entire disk.
Everything is fine until you come back from suspend -> that part of the disk is
unaccessible since the bios has locked it -> your system gets very confused.

So there's two scenarios, some people really want to use that space and others
absolutely require that the kernel doesn't touch it. Lovely :)"

In the FC3 install kernel, that area just wasn't seen by anaconda (no
CONFIG_IDE_DISK_STROKE?). In the FC4 install kernel, during the boot there is
something like 

current capacity is 66055248 sectors (33820 MB)
native  capacity is 78165360 sectors (40020 MB)
hda: Host Protected Area disabled.

So anaconda is happy using the entire disk. And everything is happy, except
the XP recovery "partition" (not a real partition :) ) gets nuked. Not a huge
deal, I suppose. But the behaviour when coming out of suspend is a lot nastier,
then parts of your harddrive just vanish.
Comment 1 Pekka Pietikäinen 2005-07-26 04:10:19 EDT
Upstream discussion at 

http://marc.theaimsgroup.com/?t=112116799200003&r=1&w=2

btw.
Comment 2 Dave Jones 2005-08-26 17:41:10 EDT

*** This bug has been marked as a duplicate of 163419 ***

Note You need to log in before you can comment on or make changes to this bug.