Bug 164148 - the /usr/lib/libgnutls-extra.* libraries dosen't have the gnutls_srp_allocate_client_credentials function
the /usr/lib/libgnutls-extra.* libraries dosen't have the gnutls_srp_allocate...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnutls (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 08:08 EDT by Denis Pugnere
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-25 08:22:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Pugnere 2005-07-25 08:08:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511

Description of problem:
I compile the libprelude-0.9.0-rc10 libraries which require some functions in the  libtls-extra libraries, such as : gnutls_srp_allocate_client_credentials gnutls_srp_1024_group_generator gnutls_srp_allocate_server_credentials gnutls_srp_set_server_credentials_function gnutls_srp_free_server_credentials

Version-Release number of selected component (if applicable):
gnutls-devel-1.0.20-3.2.1

How reproducible:
Always

Steps to Reproduce:
1. install prerequisites needed by libprelude-0.9.0-rc10 : libgpg-error, libgcrypt,   gnutls-devel : 
2. download http://prelude-ids.org/download/releases/libprelude-0.9.0-rc10.tar.gz
3. ./configure ; make


  

Actual Results:  prelude-adduser.o(.text+0x1762): In function `register_cmd':
/root/archives/libprelude-0.9.0-rc10/prelude-adduser/prelude-adduser.c:441: undefined reference to `gnutls_srp_allocate_client_credentials'
prelude-adduser.o(.text+0x1778):/root/archives/libprelude-0.9.0-rc10/prelude-adduser/prelude-adduser.c:442: undefined reference to `gnutls_srp_set_client_credentials'
server.o(.text+0x24e): In function `srp_callback':
/root/archives/libprelude-0.9.0-rc10/prelude-adduser/server.c:376: undefined reference to `gnutls_srp_1024_group_generator'
server.o(.text+0x262):/root/archives/libprelude-0.9.0-rc10/prelude-adduser/server.c:380: undefined reference to `gnutls_srp_1024_group_prime'
server.o(.text+0x4f4): In function `server_create':
/root/archives/libprelude-0.9.0-rc10/prelude-adduser/server.c:414: undefined reference to `gnutls_srp_allocate_server_credentials'
server.o(.text+0x512):/root/archives/libprelude-0.9.0-rc10/prelude-adduser/server.c:421: undefined reference to `gnutls_srp_set_server_credentials_function'
server.o(.text+0x7b9):/root/archives/libprelude-0.9.0-rc10/prelude-adduser/server.c:426: undefined reference to `gnutls_srp_free_server_credentials'
server.o(.text+0x29d): In function `srp_callback':
/root/archives/libprelude-0.9.0-rc10/prelude-adduser/server.c:384: undefined reference to `gnutls_srp_verifier'
collect2: ld returned 1 exit status
make[2]: *** [prelude-adduser] Error 1
make[2]: Leaving directory `/root/archives/libprelude-0.9.0-rc10/prelude-adduser'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/archives/libprelude-0.9.0-rc10'
make: *** [all] Error 2


Additional info:


there is no such function gnutls_srp_allocate_client_credentials in /usr/lib/libgnutls-extra.a or /usr/lib/libgnutls-extra.so : 

# nm /usr/lib/libgnutls-extra.a | grep gnutls_srp_allocate_client_credentials
nm: ext_srp.o: no symbols
nm: gnutls_srp.o: no symbols
nm: auth_srp.o: no symbols
nm: auth_srp_passwd.o: no symbols
nm: auth_srp_sb64.o: no symbols
nm: auth_srp_rsa.o: no symbols

if I compile ftp://ftp.gnutls.org/pub/gnutls/gnutls-1.0.25.tar.gz, the function  gnutls_srp_allocate_client_credentials is here : 
# nm ./libextra/.libs/libgnutls-extra.a | grep gnutls_srp_allocate_client_credentials
00000934 T gnutls_srp_allocate_client_credentials
Comment 1 Tomas Mraz 2005-07-25 08:22:03 EDT
SRP is removed from gnutls due to potential patent issues.
I'm sorry.

Note You need to log in before you can comment on or make changes to this bug.