Bug 164149 - Python gnome applets cannot request focus
Python gnome applets cannot request focus
Status: CLOSED DUPLICATE of bug 162419
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 08:13 EDT by Luca Bruera
Modified: 2013-04-02 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 06:06:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luca Bruera 2005-07-25 08:13:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.4.4

Description of problem:
The version 2.10 of gnome-python-extras does not include a wrapper for the gnome_applet_request_focus method, thus, due to the new focus policies in gnome 2.10, it is not possible to write a python applet including a text entry of a component needing keyboard focus. Old applications need to be ported to this new API, or won't be able to get focus.

Version-Release number of selected component (if applicable):
gnome-python-extras-2.10

How reproducible:
Always

Steps to Reproduce:
1.Run a python applet with a text entry
2.Click on the text entry

  

Actual Results:  No cursor in the text entry, so it is not possible to input text.

Expected Results:  Cursor to appear in the text entry field, and being able to input text.

Additional info:

A wrapper is available in the unstable release (2.11) of this component.
Comment 1 Walter Justen 2005-08-26 06:06:04 EDT
Thanks for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 162419 ***

Note You need to log in before you can comment on or make changes to this bug.