Bug 1641638 - python2-pungi has no dependencies
Summary: python2-pungi has no dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pungi
Version: 28
Hardware: All
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Lubomír Sedlář
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-22 12:12 UTC by homann.philipp
Modified: 2018-11-16 02:57 UTC (History)
6 users (show)

Fixed In Version: pungi-4.1.30-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-16 02:57:33 UTC
Type: Bug


Attachments (Terms of Use)

Description homann.philipp 2018-10-22 12:12:52 UTC
Description of problem:
I installed pungi (including its dependency python2-pungi) and had to reinstall all dependencies manually. For example createrepo, repoview python2-setools and much more.
"rpm -qR python2-pungi" showed me that there is no dependency except to the python abi itself.

Version-Release number of selected component (if applicable):
python2-pungi-4.1.28-1.fc28.noarch

How reproducible:
Run pungi will show severel import errors (depends on whats installed on your system before)

Steps to Reproduce:
1. Install python2-pungi-4.1.28-1.fc28.noarch
2. Run it!

Actual results:
Import errors because of lacking dependencies

Expected results:
No import errors.

Additional info:

Comment 1 Lubomír Sedlář 2018-10-22 12:44:48 UTC
Good catch. There is nothing executable in the python[23]-pungi subpackage, they are mostly an implementation detail. Upstream does not support using Pungi as library.

However you're totally right the dependencies somehow disappeared from the pungi-legacy package which provides /usr/bin/pungi. I'll fix it in next release.

Please note that eventually the script will be dropped completely though due to dependencies on Yum and Python 2, unless someone comes and ports it to Python 3.

Comment 2 homann.philipp 2018-10-23 07:13:08 UTC
Thats a good point. Found out that pungi-koji should be used as a replacement.
Maybe you should also think about including this information in the %summary?

Comment 3 Lubomír Sedlář 2018-10-31 12:15:10 UTC
The problem is that it is not a direct replacement. It requires a Koji instance to perform a lot of the tasks.

Comment 4 Fedora Update System 2018-10-31 12:16:19 UTC
pungi-4.1.30-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-731fb3f951

Comment 5 Fedora Update System 2018-10-31 17:31:59 UTC
pungi-4.1.30-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-731fb3f951

Comment 6 Fedora Update System 2018-11-16 02:57:33 UTC
pungi-4.1.30-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.