Bug 1641672 - "ovn-nbctl - LBs - daemon" test always fails on mock / brew
Summary: "ovn-nbctl - LBs - daemon" test always fails on mock / brew
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch2.10
Version: 7.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Numan Siddique
QA Contact: haidong li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-22 13:44 UTC by Timothy Redaelli
Modified: 2019-01-07 08:51 UTC (History)
8 users (show)

Fixed In Version: openvswitch2.10-2.10.0-24.el7fdn
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-07 08:51:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0029 None None None 2019-01-07 08:51:23 UTC

Description Timothy Redaelli 2018-10-22 13:44:19 UTC
"ovn-nbctl - LBs - daemon" test (make check) always fails on mock / brew since it tries to resolve an hostname, but on mock network is not available. it hangs and it's killed by SIGALARM.

AT_CHECK([ovn-nbctl -vsocket_util:off lb-add lb0 30.0.0.1a 192.168.10.10:80,192.168.10.20:80], [1], [],
[ovn-nbctl: 30.0.0.1a: should be an IP address (or an IP address and a port number with : as a separator).
])

I've got the same failure also on upstream OVS master branch.

Comment 2 Numan Siddique 2018-10-22 15:50:28 UTC
Submitted the patch u/s to fix the issue - https://patchwork.ozlabs.org/patch/987789/

Comment 5 haidong li 2018-11-20 10:31:14 UTC
reproduced on old version:
[root@hp-dl580g7-01 ~]# rpm -qa | grep openvswitch
openvswitch2.10-ovn-central-2.10.0-10.el7fdp.x86_64
openvswitch-selinux-extra-policy-1.0-8.el7fdp.noarch
openvswitch2.10-ovn-common-2.10.0-10.el7fdp.x86_64
openvswitch2.10-ovn-host-2.10.0-10.el7fdp.x86_64
openvswitch2.10-2.10.0-10.el7fdp.x86_64
[root@hp-dl580g7-01 ~]# cat  /etc/resolv.conf
cat: /etc/resolv.conf: No such file or directory
[root@hp-dl580g7-01 ~]# ovn-nbctl -vsocket_util:off lb-add lb0 b 192.168.10.10:80,192.168.10.20:80
^C^C^C

=======================================================================
verified on the latest version:

[root@dell-per730-57 ~]# uname -a
Linux dell-per730-57.rhts.eng.pek2.redhat.com 3.10.0-957.el7.x86_64 #1 SMP Thu Oct 4 20:48:51 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@dell-per730-57 ~]# 
[root@dell-per730-57 ~]# rpm -qa | grep openvswitch
kernel-kernel-networking-openvswitch-ovn-1.0-108.noarch
openvswitch2.10-ovn-central-2.10.0-28.el7fdp.x86_64
openvswitch-selinux-extra-policy-1.0-8.el7fdp.noarch
openvswitch2.10-ovn-common-2.10.0-28.el7fdp.x86_64
openvswitch2.10-ovn-host-2.10.0-28.el7fdp.x86_64
openvswitch2.10-2.10.0-28.el7fdp.x86_64
[root@dell-per730-57 ~]# ovn-nbctl -vsocket_util:off lb-add lb0 30.0.0.1a \
>   192.168.10.10:80,192.168.10.20:80
ovn-nbctl: 30.0.0.1a: should be an IP address (or an IP address and a port number with : as a separator).
[root@dell-per730-57 ~]# ovn-nbctl  lb-add lb0 30.0.0.1a   192.168.10.10:80,192.168.10.20:80
2018-11-20T09:17:13Z|00002|socket_util|ERR|30.0.0.1a: bad IP address "30.0.0.1a"
ovn-nbctl: 30.0.0.1a: should be an IP address (or an IP address and a port number with : as a separator).

Comment 10 errata-xmlrpc 2019-01-07 08:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0029


Note You need to log in before you can comment on or make changes to this bug.