Bug 1641797 - Missing Requires: python2-pygments
Summary: Missing Requires: python2-pygments
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python2-ipython
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Lumír Balhar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1642470
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-22 19:15 UTC by Mattias Ellert
Modified: 2018-11-02 12:52 UTC (History)
4 users (show)

Fixed In Version: python2-ipython-5.8.0-2.fc28 python2-ipython-5.8.0-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-02 12:52:01 UTC


Attachments (Terms of Use)
Backport fix for new sqlite version (2.22 KB, patch)
2018-10-30 22:32 UTC, Mattias Ellert
no flags Details | Diff

Description Mattias Ellert 2018-10-22 19:15:20 UTC
Description of problem:

    from IPython import get_ipython
/usr/lib/python2.7/site-packages/IPython/__init__.py:48: in <module>
    from .core.application import Application
/usr/lib/python2.7/site-packages/IPython/core/application.py:25: in <module>
    from IPython.core import release, crashhandler
/usr/lib/python2.7/site-packages/IPython/core/crashhandler.py:28: in <module>
    from IPython.core import ultratb
/usr/lib/python2.7/site-packages/IPython/core/ultratb.py:119: in <module>
    from IPython.core import debugger
/usr/lib/python2.7/site-packages/IPython/core/debugger.py:37: in <module>
    from IPython.utils import PyColorize, ulinecache
/usr/lib/python2.7/site-packages/IPython/utils/PyColorize.py:57: in <module>
    from .colorable import Colorable
/usr/lib/python2.7/site-packages/IPython/utils/colorable.py:13: in <module>
    import pygments
E   ImportError: No module named pygments

Version-Release number of selected component (if applicable):

python2-ipython-5.8.0-1.fc28.noarch
python2-ipython-5.8.0-1.fc29.noarch
python2-ipython-5.8.0-1.fc30.noarch

How reproducible:

Always

Steps to Reproduce:
1. Install python2-ipython without Recommends (e.g. in mock)
2. Try to use it,

Actual results:

Building packages that depend on python2-ipython fails in mock or koji due to missing dependency python2-pygments.

Expected results:

Successful builds

Additional info:

python2-ipython has a Requires: on python2-prompt_toolkit, and python2-prompt_toolkit used to have a Requires: on python2-pygments, so this used to work even though the dependency was not listed in python2-ipython.

However, the Requires: in python2-prompt_toolkit has been downgraded to a Recommends: in the latest versions of the package, so python2-ipython can not rely on this chain of Requires: anymore.

python3-ipython correctly Requires: python3-pygments.

Comment 1 Fedora Update System 2018-10-23 16:02:20 UTC
python2-ipython-5.8.0-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-da0deaea14

Comment 2 Fedora Update System 2018-10-23 16:12:36 UTC
python2-ipython-5.8.0-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-759e378c35

Comment 3 Lumír Balhar 2018-10-23 16:14:45 UTC
Updates for f29 and f28 are ready but I am not able to build the new version in rawhide because there is no python2-matplotlib.

Koji build in rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=30416677

Comment 4 Fedora Update System 2018-10-23 21:31:21 UTC
python2-ipython-5.8.0-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-759e378c35

Comment 5 Mattias Ellert 2018-10-24 08:09:12 UTC
(In reply to Lumír Balhar from comment #3)
> Updates for f29 and f28 are ready but I am not able to build the new version
> in rawhide because there is no python2-matplotlib.
> 
> Koji build in rawhide:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=30416677

python-matplotlib is in the same situation as python-ipython, in that the latest version is python3 only.

When python-ipython was updated to version 6, which only provides python3-ipython, the python2-ipython source package was created to provide the python2-ipython version 5 binary package. And all was well.

Similarly, when python-matplotlib was updated to version 3, which only provides python3-ipython, the python2-matplotlib source package was created to provide the python2-matplotlib version 2 binary package. And all was well - for a while.

Unfortunately, the python2-matplotlib package has since been retired thereby introducing all the breakages the introduction of the package was intended to avoid.

Dropping python2-matplotlib was clearly too disruptive at this point.

Comment 6 Petr Viktorin 2018-10-24 08:47:13 UTC
python2-matplotlib was retired in Fedora by this commit: https://src.fedoraproject.org/rpms/python2-matplotlib/c/61325fb06712da5fca46a1577bd39b083312c09c?branch=master

This broke all of the dependencies (24 direct ones, according to a rawhide repoquery).

Tibbs, what would it take to undo the retirement?

Comment 7 Miro Hrončok 2018-10-24 09:15:25 UTC
> Dropping python2-matplotlib was clearly too disruptive at this point.

I agree.

Comment 8 Jason Tibbitts 2018-10-24 12:52:16 UTC
Don't ask me; I never wanted it to exist in the first place.

Comment 9 Petr Viktorin 2018-10-24 14:42:42 UTC
(In reply to Petr Viktorin from comment #6)
> Tibbs, what would it take to undo the retirement?

Answered in #1642470: it would take someone willing to maintain python2-matplotlib.
Also, quoting Bug #1642470 comment #1:
> there was a call for someone to maintain this
> previously which received no response but maybe the alternative (remove
> packages like python2-ipython) will be enough to get someone to step up.

Comment 10 Fedora Update System 2018-10-24 15:40:41 UTC
python2-ipython-5.8.0-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-da0deaea14

Comment 11 Mattias Ellert 2018-10-24 16:50:59 UTC
(In reply to Petr Viktorin from comment #9)
> (In reply to Petr Viktorin from comment #6)
> > Tibbs, what would it take to undo the retirement?
> 
> Answered in #1642470: it would take someone willing to maintain
> python2-matplotlib.
> Also, quoting Bug #1642470 comment #1:
> > there was a call for someone to maintain this
> > previously which received no response but maybe the alternative (remove
> > packages like python2-ipython) will be enough to get someone to step up.

I saw the call. I was hoping someone more directly affected would pick it up. I maintain a package that depend on a package that depends on it, so I am a bit peripheral to the issue.

If there is noone else I can do it, but I do think that someone who use the package more regularly or maintain a package that directly depend on it would be able to do a better job.

Comment 12 Miro Hrončok 2018-10-24 17:10:18 UTC
BTW here is a rawhide scratchbuild of ipython without matplotlib (I needed to add numpy that is in fact needed and was previously indirectly brought in by matplotlib):

https://koji.fedoraproject.org/koji/taskinfo?taskID=30439793

I see some failures, but I'm unsure if they are relevant to missing matplotlib or not.

Comment 13 Mattias Ellert 2018-10-25 02:59:50 UTC
A local Fedora Rawhide mockbuild with python2-matplotlib installed manually in the mock buildroot using packages from koji succeeds.

python2-matplotkib packages downloaded from here:
https://koji.fedoraproject.org/koji/buildinfo?buildID=1146254

Comment 14 Fedora Update System 2018-10-25 22:11:24 UTC
python2-ipython-5.8.0-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2018-10-30 17:30:53 UTC
python2-ipython-5.8.0-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Mattias Ellert 2018-10-30 22:32:37 UTC
Created attachment 1499144 [details]
Backport fix for new sqlite version

python2-matplotlib is available in rawhide again.

The python2-ipython needs a patch in rawhide due to a new sqlite version. I backported the fix from master to 5.x and created a PR upstream:
https://github.com/ipython/ipython/pull/11470

The patch is also attached here.

Comment 17 Mattias Ellert 2018-10-31 16:15:44 UTC
Rawhide scratch build with the above patch applied succeeds:
https://koji.fedoraproject.org/koji/taskinfo?taskID=30578199

Comment 18 Lumír Balhar 2018-11-02 12:52:01 UTC
Build: https://koji.fedoraproject.org/koji/taskinfo?taskID=30607481


Note You need to log in before you can comment on or make changes to this bug.