Bug 1641798 - [RHHI] Hosted Engine migration fails in gluster storage domain [rhel-7.6.z]
Summary: [RHHI] Hosted Engine migration fails in gluster storage domain [rhel-7.6.z]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.6
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Michal Privoznik
QA Contact: Han Han
URL:
Whiteboard:
: 1633517 (view as bug list)
Depends On: 1640465
Blocks: 1640467
TreeView+ depends on / blocked
 
Reported: 2018-10-22 19:17 UTC by Oneata Mircea Teodor
Modified: 2019-04-28 10:49 UTC (History)
16 users (show)

Fixed In Version: libvirt-4.5.0-10.el7_6.3
Doc Type: Bug Fix
Doc Text:
Prior to this update, migrating a virtual machine (VM) failed when the VM contained a symbolic link to a GlusterFS storage. With this update, the libvirt service establishes disk paths correctly, and VMs with symlinked GlusterFS storage can be migrated as expected.
Clone Of: 1640465
Environment:
Last Closed: 2018-11-27 01:22:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3669 None None None 2018-11-27 01:22:57 UTC

Description Oneata Mircea Teodor 2018-10-22 19:17:22 UTC
This bug has been copied from bug #1640465 and has been proposed to be backported to 7.6 z-stream (EUS).

Comment 8 Gobinda Das 2018-11-06 08:58:43 UTC
*** Bug 1633517 has been marked as a duplicate of this bug. ***

Comment 10 Han Han 2018-11-12 09:36:29 UTC
Verified on:
libvirt-4.5.0-10.virtcov.el7_6.3.x86_64
glusterfs-3.12.2-19.el7rhgs.x86_64
qemu-kvm-rhev-2.12.0-19.el7_6.2.x86_64


SC1:Test VM migraition on symlink of shareable mounted glusterfs
1. Mount glusterfs on dst and src host:
# mount -t glusterfs 10.66.4.183:/gv0 /mnt/

2. Make symlinks on dst and src hosts:
# ln -s /mnt/glusterfs /var/lib/libvirt/images/glusterfs

3. Prepare a running VM whose image on then symlink dir:
# virsh domblklist rhel7                                                                                                                         
Target     Source
------------------------------------------------
vda        /var/lib/libvirt/images/glusterfs/A.qcow2

# virsh -k0 -K0 migrate rhel7 qemu+ssh://root@fjin-5-190/system --verbose                   
Migration: [100 %]

Migrate back:
# virsh -k0 -K0 migrate rhel7 qemu+ssh://root@lab.test.me/system --verbose
root@lab.test.me's password: 
Migration: [100 %]

Check R/W on VM:
# echo xx>xx
# cat xx
xx


SC2: Test VM migraition on mounter glusterfs directly
1. Mount glusterfs on dst and src host:
# mount -t glusterfs 10.66.4.183:/gv0 /mnt/

2. Prepare a running VM whose image on then symlink dir:
# virsh domblklist rhel7                                                                                                                         
Target     Source
------------------------------------------------
vda         /mnt/glusterfs/A.qcow2

# virsh -k0 -K0 migrate rhel7 qemu+ssh://root@fjin-5-190/system --verbose                   
Migration: [100 %]

Migrate back:
# virsh -k0 -K0 migrate rhel7 qemu+ssh://root@lab.test.me/system --verbose
root@lab.test.me's password: 
Migration: [100 %]

Check R/W on VM:
# echo xx>xx
# cat xx
xx

Comment 11 Han Han 2018-11-12 09:42:04 UTC
Could you please try this new libvirt package on RHHI? Thanks

Comment 13 errata-xmlrpc 2018-11-27 01:22:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3669

Comment 14 SATHEESARAN 2018-11-27 06:19:24 UTC
(In reply to Han Han from comment #11)
> Could you please try this new libvirt package on RHHI? Thanks

This time when I tried to migrate VMs from one host to another using RHV Manager, I hit totally a different issue. I will be raising a new bug[1] for that issue

[1] - https://bugzilla.redhat.com/show_bug.cgi?id=1653556


Note You need to log in before you can comment on or make changes to this bug.