Bug 164191 - warning about hard links in /proc when running find
warning about hard links in /proc when running find
Status: CLOSED DUPLICATE of bug 162418
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Viro
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 16:42 EDT by John Griffiths
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-28 03:40:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2005-07-25 16:42:51 EDT
Description of problem:
When I run find on / , I get the following warning:

find: WARNING: Hard link count is wrong for /proc: this may be a bug in your
filesystem driver.  Automatically turning on find's -noleaf option.  Earlier
results may have failed to include directories that should have been searched.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1398_FC4 (/lib/modules/2.6.12-1.1398_FC4/kernel/fs/ext3/ext3.ko)
findutils-4.2.20-1

How reproducible:
everytime

Steps to Reproduce:
1. run find / -name test (or and name just to limit output)
2.
3.
  
Actual results:
Get warning:
find: WARNING: Hard link count is wrong for /proc: this may be a bug in your
filesystem driver.  Automatically turning on find's -noleaf option.  Earlier
results may have failed to include directories that should have been searched.


Expected results:
Would not expect warning.

Additional info:
Here is the root mount info:
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
Comment 1 Dave Jones 2005-07-28 03:40:31 EDT

*** This bug has been marked as a duplicate of 162418 ***

Note You need to log in before you can comment on or make changes to this bug.