Bug 164193 - During boot time, portmapper crashes when remote clients contact the portmapper at a rate faster than 4 times per second.
During boot time, portmapper crashes when remote clients contact the portmapp...
Status: CLOSED DUPLICATE of bug 164192
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: portmap (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 17:07 EDT by Charles Whalen
Modified: 2015-01-07 19:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-26 10:29:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Whalen 2005-07-25 17:07:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3) Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
During boot time, portmapper crashes when remote clients contact the portmapper at a rate faster than 4 times per second.  While initiating many rpcinfo -p host requests, the portmapper appears to answer to first few requests, then hangs.

From netstat, I see many half open connections. (See below).  I can reproduce
this by running a script many times in parallel. (See below)

The problem was noticed when ypbind service was trying to start.

I worked around this problem by using IPTABLES and block all remote client connections to port 111.

Thank You



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run many copies of script in additional inforamtion field
2. Reboot computer
3. Watch system hang at ypbind service startup.  Can not contact portmapper.
  

Additional info:


#!/bin/csh

set x = 0
while ( $x <1000 )
    rpcinfo -p HOST &
    set x = `expr $x + 1`
    usleep 100000
end 

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State      
tcp        0      0 0.0.0.0:32768               0.0.0.0:*                   LISTEN      
tcp        0      0 0.0.0.0:32769               0.0.0.0:*                   LISTEN      
tcp        0      0 0.0.0.0:513                 0.0.0.0:*                   LISTEN      
tcp        0      0 0.0.0.0:514                 0.0.0.0:*                   LISTEN      
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      
tcp        0      0 127.0.0.1:111               127.0.0.1:32775             SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:905               SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:901               SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:903               SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:902               SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:32776             SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:934               SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:938               SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:951               SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:914               SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:909               SYN_RECV    
tcp        0      0 127.0.0.1:111               127.0.0.1:32777             SYN_RECV
Comment 1 Suzanne Hillman 2005-07-26 10:29:38 EDT

*** This bug has been marked as a duplicate of 164192 ***

Note You need to log in before you can comment on or make changes to this bug.