Bug 164202 - Installer stops and sends error to floppy /sda
Installer stops and sends error to floppy /sda
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-25 17:47 EDT by Mike Conan
Modified: 2008-02-19 23:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 23:31:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error file dumped by Anaconda (880.28 KB, text/plain)
2005-07-25 17:55 EDT, Mike Conan
no flags Details

  None (edit)
Description Mike Conan 2005-07-25 17:47:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
Attempt install form bootable ISO on CD. Install completes throught formating and workstation package selection then gives error about addressing disk sda.
System downloads to floppy error data and reboots.
Same sequence on multiple tries, same error despite different effort to format disk in various formats.
System is Abit NF7 mother board, 1 SCSI drive with Win 2k, Adaptec 29160N adapter
one SATA drive as Dos Boot ( no Raid) and one IDE drive 14 Gbyte) reserved for Fedora as drive hda.   Sata and SCSI unchecked in either auto format/partition or manual format /partition. Several different partition sizes tried on hda - same problem.  Why does system look for sdX when I install only on hda.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot to FC4 ISO CD
2.Follow either text or graphical install
3.either partition manually or automatically to blank IDE unformatted disk.
4. Select this disk for boot (/boot) or (/) ext3 format and 500 meg swap.
Select workstation and default packages. 
  

Actual Results:  System appears to format disk but halts on package install,  I copy errata to floppy and system reboots.  Error message is something about error with disk SDA
though disk HDA is formated to receive Fedora

Expected Results:  Operating system should have installed on disk reserved for Linux

Additional info:
Comment 1 Mike Conan 2005-07-25 17:55:09 EDT
Created attachment 117135 [details]
Error file dumped by Anaconda
Comment 2 Jeremy Katz 2005-07-26 00:18:21 EDT
There are write errors trying to write the partition table to your drive -- are
you sure the drive isn't dying?
Comment 3 Mike Conan 2005-07-26 12:11:10 EDT
"There are write errors trying to write the partition table to your drive -- are
you sure the drive isn't dying?"
Answer -
IDE disk appears OK.  Have tried several methods of partitioning including
'Partition Magic' for ext3 or ext2. Also form clean, empty, unformated disk (all
14 Gb)- All seem to take and disk appears OK Tried Anaconda partition in manual
and automatic then with Anaconda I get the error you see on  floppy errata disk.
Strange thing is text box in Anaconda ( just before request to insert floppy for
error dump)says can't write to disk SDx which is not selected for install but
IDE (HDx) is selected. Does floppy error data indicate which disk it is failing
to write to?  Disks on Computer are SATA(boot +DOS), SCSI(Win2K), IDE
-unformated for Linux  Thanks 
Comment 4 Mike Conan 2005-07-27 23:17:16 EDT
After several more tries - have the following information:
My BIOS (latest AWARD)allows setting the priority of hard disk boot sequence. My
3 disks are SCSI( WinNt kernel), IDE( new Disk installed and reserved for
Fedora) and SATA(Boot disk with boot.ini for Win2k and DOS).  If I change the
order of disks in BIOS the system will not boot Win NT until the order is re-set
to the order originally selected when Win2k was installed (SATA,SCSI).  The
forgoing is for info and not the core problem. 

 I can un-plug the SATA and SCSI disks, load Fedrora and re-boot to Fedora OK
(Full install and boot works with just IDE operative).  I can un-plug only SCSI
and load Fedora OK but can't boot Fedora for reasons probably related to
sequence issues described above. The Core PROBLEM is Anaconda does not appear to
work with Adaptec 29160 SCSI adapter and/or SCSI III drives.  All disks other
than IDE(ATA)including USB disks are labeled SDx by Linux and this may be a
confusing issue.  Fedora say "Problem communicating with SDA" (SCSI?)and crashes
on install - despite all install placed on IDE drive and all SDx drives
un-checked during Druid partitioning.
Comment 5 Chris Lumens 2005-08-03 17:04:19 EDT
anaconda is still looking at your other drives in order to find out what
filesystems are on those.  We need this information to know whether to offer you
the update option, if dual booting needs to be set up, and so forth.  If your
hardware is known to be working properly, then this looks to be a kernel problem.
Comment 6 Mike Conan 2005-08-04 09:59:29 EDT
I currently use Dual booting under System Commander7 into Dos6.22 and Win2K.
Fedora load fails even with System commander completly removed. System has
operated for a year with no problems and is virus free (including MBR).
Note for reference:
http://forums.fedoraforum.org/showthread.php?s=2b54ba802ec2d1f207b19df7422fc482&t=50383&page=1&pp=15
describing difficulty with BIOS re-ordering disk numbering similar to my problem
where I can load Fedora and run Fedora when SCSI drive is removed from system.
When I Add back SCSI with Fedora installed I can not run Fedora at all but can
run Win2k if I re-order disk priority (disk numbering in BIOS).
Disk info is as follows:
Disk Info on Abit NF-7S motherboard (AMD processor)Dual Boot To true Dos6.22 or
Win2k under 'System Commander'
Windows 2000 
    Total Physical Memory (bytes):  536,330,240
    Used Physical Memory: (bytes):  161,005,568
    Maximum Page File Size: (bytes):  879,472,640
    Current Page File Size: (bytes):  145,543,168
Disk1 - 17 GB SCSI ( contains Win2K kern on D:)
===========================================================================================================
Partition Information for Disk 1:    17,500.5 Megabytes
Volume         PartType    Status    Size MB    PartSect  #   StartSect 
TotalSects   UsedSects   FreeSects
===========================================================================================================
D:             FAT16B      Pri       2,047.3           0  0          63  
4,192,902   4,192,902           0
               ExtendedX   Pri       8,973.8           0  1   4,192,965 
18,378,360  18,378,360           0
               EPBR        Log       2,047.3        None --   4,192,965  
4,192,965   4,192,965           0
H:             FAT16B      Log       2,047.3   4,192,965  0   4,193,028  
4,192,902   4,192,902           0
               EPBR        Log       6,926.5   4,192,965  1   8,385,930 
14,185,395  14,185,395           0
I:             FAT16B      Log       2,047.3   8,385,930  0   8,385,993  
4,192,902   4,192,902           0
               EPBR        Log       4,879.1   8,385,930  1  12,578,895  
9,992,430   9,992,430           0
J:J SCSI       FAT32       Log       4,879.1  12,578,895  0  12,578,958  
9,992,367   9,992,367           0
               Unallocated Pri       6,479.3        None --  22,571,325 
13,269,690           0  13,269,690
---------
Disk 2 ATA/IDE reserved for Linux
===========================================================================================================
Partition Information for Disk 2:    14,653.0 Megabytes
Volume         PartType    Status    Size MB    PartSect  #   StartSect 
TotalSects   UsedSects   FreeSects
===========================================================================================================
               Unallocated Pri      14,653.0        None --          63 
30,009,357           0  30,009,357

Disk 3 SATA with boot sector for Win2K and Dos6.22 under 'System Commander' Boot
selector program
===========================================================================================================
Partition Information for Disk 3:    35,299.1 Megabytes
Volume         PartType    Status    Size MB    PartSect  #   StartSect 
TotalSects   UsedSects   FreeSects
===========================================================================================================
C:             FAT16B      Pri,Boot    509.8           0  0          63  
1,044,162   1,044,162           0
               Linux Ext2  Pri        101.10           0  2   1,044,225    
208,845     208,845           0
               Unallocated Pri       1,435.5        None --   1,253,070  
2,939,895           0   2,939,895
               ExtendedX   Pri      18,975.2           0  1   4,192,965 
38,861,235  38,861,235           0
               EPBR        Log       2,047.3        None --   4,192,965  
4,192,965   4,192,965           0
E:             FAT16B      Log       2,047.3   4,192,965  0   4,193,028  
4,192,902   4,192,902           0
               EPBR        Log       2,047.3   4,192,965  1   8,385,930  
4,192,965   4,192,965           0
F:             FAT16B      Log       2,047.3   8,385,930  0   8,385,993  
4,192,902   4,192,902           0
               EPBR        Log      14,880.5   8,385,930  1  12,578,895 
30,475,305  30,475,305           0
G:G SATA F32   FAT32       Log      14,880.5  12,578,895  0  12,578,958 
30,475,242  30,475,242           0
               Unallocated Pri      14,276.5        None --  43,054,200 
29,238,300           0  29,238,300

Note: Linux Ext3 added to SATA (Disk3) drive below ~600 Meg for /Boot under
Fedora (added this week) but Fedora 
Anaconda still refuses to load and freezes at "not able to communicate with
SDA".  Last 5 tries where 
Fedora also refused to load were with Disk 3's first 2047 MB ( Volume C:) all
set to Fat16B ( no ext3).
Comment 7 Christian Iseli 2007-01-19 19:46:25 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 8 Red Hat Bugzilla 2007-06-11 22:53:13 EDT
requested by Jams Antill
Comment 9 petrosyan 2008-02-19 23:31:59 EST
Fedora Core 4 is no longer maintained.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.

Note You need to log in before you can comment on or make changes to this bug.