Bug 1642044 - [RFE] virt-p2v UI should give the option to shutdown after conversion is finished
Summary: [RFE] virt-p2v UI should give the option to shutdown after conversion is fini...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.5
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard: P2V
Depends On: 1621895
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-23 13:13 UTC by Eric Lavarde
Modified: 2019-08-06 12:45 UTC (History)
8 users (show)

Fixed In Version: libguestfs-1.40.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 12:44:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
virt-p2v UI (78.21 KB, image/png)
2019-03-01 07:54 UTC, liuzi
no flags Details
virt-p2v add a new button (82.68 KB, image/png)
2019-04-23 09:47 UTC, liuzi
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2096 None None None 2019-08-06 12:45:45 UTC

Description Eric Lavarde 2018-10-23 13:13:20 UTC
Description of problem:

Once virt-p2v is finished converting, the UI offers only the choice to do nothing or to reboot. In order to avoid having twice the same server on the network (possibly with same IP, FQDN and/or MAC address), it would be good to have an additional button to shutdown the physical server after conversion, before the converted VM is started.

Version-Release number of selected component (if applicable):

Version     : 1.36.10
Release     : 1.el7

How reproducible:

RFE, always.

Steps to Reproduce:
1. boot from the p2v ISO
2. finish the migration process

Actual results:

There is only a Reboot button, you can press it or not.

Expected results:

Have a shutdown button in addition, to reach a similar approach as with the following kernel parameters:

       p2v.post=poweroff
       p2v.post=reboot

Additional info:

n/a

Comment 3 Pino Toscano 2018-11-05 17:32:20 UTC
Patch series posted:
https://www.redhat.com/archives/libguestfs/2018-November/msg00029.html

Comment 5 Pino Toscano 2019-01-17 11:49:20 UTC
This bug will be fixed by the rebase scheduled for RHEL 7.7, see bug 1621895.

Comment 7 liuzi 2019-03-01 07:54:46 UTC
Created attachment 1539747 [details]
virt-p2v UI

Comment 8 liuzi 2019-03-01 07:55:28 UTC
Verify bug with builds:
virt-p2v-1.40.2-1.el7.iso
libguestfs-1.40.2-1.el7.x86_64
virt-v2v-1.40.2-1.el7.x86_64

Steps:
1. Prepare a guest and boot from the virt-p2v ISO
2. After virt-p2v conversion,check if the UI have an additional button to shutdown the physical server after conversion,before the converted VM is started.

Result:
The UI have an additional button to shutdown the physical server after conversion,before the converted VM is started.pls refer to screenshot:virt-p2v UI.

Comment 9 liuzi 2019-04-23 09:47:11 UTC
Created attachment 1557518 [details]
virt-p2v add a new button

Comment 10 liuzi 2019-04-23 09:51:49 UTC
Verify bug with builds:
virt-p2v-1.40.2-1.el7.iso
virt-v2v-1.40.2-3.el7.x86_64
libguestfs-1.40.2-3.el7.x86_64

Steps:
1. Prepare a guest and boot from the virt-p2v ISO
2. After virt-p2v conversion,check if the UI have an additional button to shutdown the physical server after conversion,
3. Press the shutdown button and choose the shutdown option to check if the server can be turned off. please refer to screenshot2:p2v add a new button.

Result:The UI have an additional button to shutdown the physical server after conversion and the server can be turned off successfully.so change the bug from ON_QA to VERIFIED.

Comment 12 errata-xmlrpc 2019-08-06 12:44:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2096


Note You need to log in before you can comment on or make changes to this bug.