Bug 1642079 - Add missing directory ownership
Summary: Add missing directory ownership
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc-arm-linux-gnu
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1642037
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-23 14:51 UTC by Nicolas Chauvet (kwizart)
Modified: 2019-09-22 11:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-22 11:30:13 UTC


Attachments (Terms of Use)
owns all directories for sys-root (2.68 KB, patch)
2018-10-23 14:52 UTC, Nicolas Chauvet (kwizart)
no flags Details | Diff
Update changelog (948 bytes, patch)
2018-10-23 14:52 UTC, Nicolas Chauvet (kwizart)
no flags Details | Diff

Description Nicolas Chauvet (kwizart) 2018-10-23 14:51:53 UTC
Description of problem:
When looking at installed glibc-arm-linux-gnu, there are several directories not owned by the package

Version-Release number of selected component (if applicable):
current version

How reproducible:
always

Steps to Reproduce:
1. dnf install glibc-arm-linux-gnu 
2. rpm -qf /usr/arm-linux-gnu/sys-root
3.

Actual results:
directories not owned

Expected results:
directories should be owned by the package.

Additional info:
Patch will be provided.

Comment 1 Nicolas Chauvet (kwizart) 2018-10-23 14:52:34 UTC
Created attachment 1496710 [details]
owns all directories for sys-root

Comment 2 Nicolas Chauvet (kwizart) 2018-10-23 14:52:54 UTC
Created attachment 1496711 [details]
Update changelog

Comment 3 Nicolas Chauvet (kwizart) 2018-10-23 14:57:11 UTC
Seems like header path should be
%global headerspath %{cross_sysroot}%{_prefix}/include

Comment 4 Nicolas Chauvet (kwizart) 2018-10-23 15:20:53 UTC
(unrelated failure on f30)
https://koji.fedoraproject.org/koji/taskinfo?taskID=30419142

Testing on f28

Comment 5 Nicolas Chauvet (kwizart) 2018-10-23 15:37:05 UTC
same for f28:
https://koji.fedoraproject.org/koji/taskinfo?taskID=30419461

/usr/bin/arm-linux-gnu-ld: skipping incompatible /usr/lib/gcc/arm-linux-gnueabi/8/libgcc_eh.a when searching for -lgcc_eh

I wonder if this is caused by the koji setting using armv7hl-linux-gnu instead of arm-linux-gnueabi or arm-linux-gnueabihf ?!

Comment 6 Nicolas Chauvet (kwizart) 2018-11-05 16:13:17 UTC
ping ? any advices on this general issue ?

Comment 7 Tom "spot" Callaway 2018-11-07 15:35:57 UTC
(In reply to Nicolas Chauvet (kwizart) from comment #5)
> same for f28:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=30419461
> 
> /usr/bin/arm-linux-gnu-ld: skipping incompatible
> /usr/lib/gcc/arm-linux-gnueabi/8/libgcc_eh.a when searching for -lgcc_eh
> 
> I wonder if this is caused by the koji setting using armv7hl-linux-gnu
> instead of arm-linux-gnueabi or arm-linux-gnueabihf ?!

I have no idea how to fix this issue. :/

Comment 8 Tom "spot" Callaway 2018-11-07 16:03:10 UTC
That said, I've merged your changes into rawhide, so if/when this builds again, your fixes will come along.

Comment 9 Ben Cotton 2019-08-13 17:03:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 10 Ben Cotton 2019-08-13 19:41:50 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 11 Miro Hrončok 2019-09-22 11:30:13 UTC
Automation has figured out the package is retired in Fedora 31.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement


Note You need to log in before you can comment on or make changes to this bug.