Bug 1642189 - default ceph-disk back to to bluestore
Summary: default ceph-disk back to to bluestore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 3.2
Assignee: Josh Durgin
QA Contact: Parikshith
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-10-23 22:57 UTC by Ken Dreyer (Red Hat)
Modified: 2019-01-03 19:02 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-12.2.8-40.el7cp Ubuntu: ceph_12.2.8-38redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1572722 None None None 2018-12-14 15:49:44 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:22 UTC

Internal Links: 1572722

Description Ken Dreyer (Red Hat) 2018-10-23 22:57:26 UTC
Description of problem:
We patched ceph-disk to default to filestore in RH Ceph Storage 3.1 (bz 1572722).

In RH Ceph Storage 3.2 we need to drop these patches so ceph-disk defaults to BlueStore, like it does in Luminous upstream.

Version-Release number of selected component (if applicable):
ceph-12.2.8-20.el7cp

How reproducible:
always

Steps to Reproduce:
1. Install an OSD node
2. Run ceph-disk --help

(Alternatively, see the test cases described in bz 1572722 when we originally patched the default to filestore)

Actual results:
ceph-disk defaults --filestore

Expected results:
ceph-disk should default to --bluestore

Additional info:
The exact downstream patches we must drop for this:
1. "ceph-disk: default to --filestore"
2. "ceph-disk: revise the help message for "prepare" command"

Comment 1 Vikhyat Umrao 2018-10-23 23:31:50 UTC
Ken - I think the rebase to 12.2.8 should have already done it. It should have dropped all the patches which changed it to filestore as it was only downstream change.

Comment 2 Vikhyat Umrao 2018-10-23 23:43:35 UTC
(In reply to Vikhyat Umrao from comment #1)
> Ken - I think the rebase to 12.2.8 should have already done it. It should
> have dropped all the patches which changed it to filestore as it was only
> downstream change.

https://github.com/ceph/ceph/pull/21813 This was closed in upstream as it was opened only for upstream testing I think 12.2.8 should be defaulting to bluestore.

Comment 12 errata-xmlrpc 2019-01-03 19:02:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.